v430.x broke LightDM

Using

sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt-get update && sudo apt-get install nvidia-430 -y && sudo apt-get install nvidia-settings -y

I installed v430 and after reboot the booting process got stuck at this screen, telling me it failed to start LightDM plus something else failed but the details on the latter are obscure. Good thing I have a 2 days old clonezilla backup and I managed to restore the system to a perfect state.
Below is a screenshot of the screen indicating the problem.
The OS and hardware are: Linux Mint 18.3 Cinnamon x64, Palit GTX 1050 Ti 4GB.

P.S. The last perfectly working driver (before I tried 430) was nvidia-418.56.

Works fine here with lightdm

$ inxi -GS
System:    Host: leigh.computer-desktop Kernel: 5.0.9-301.fc30.x86_64 x86_64 bits: 64 Desktop: Cinnamon 4.0.10 
           Distro: Fedora release 30 (Thirty) 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 430.09 
           Display: x11 server: Fedora Project X.org 1.20.4 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.09

When stuck, check if you’re able to switch to a VT to log in using ctrl+alt+f1 or f2. Then, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/
To revert the driver, you should be able to just hold down shift on boot and choose ‘recovery’.

Just to second you that I have the same problem. I fixed it by getting into recovery mode, press ctrl+alt+f1 to get to terminal, sudo apt remove nvidia-430 then sudo apt install nvidia-418 and reboot

Ubuntu 16.04 GTX1070