I’m using VS 2010 (waiting on the 2012 release for Nsight). I have Nsight loaded and it works properly for existing and newly created C# projects. However, the Nsight User Properties doesn’t appear when I switch to a VB.NET project. I receive the following error if I try to start a GPU or CUDA debug:

Nsight Debug
The Nsight debugger was not able to start because the program ‘’ is invalid. Please verify the output file name in Visual Studio, and the Nsight UserProperties | Launch Settings | Launch External Program setting. This must be an absolute path.

Does anyone know what is missing in default VB.NET projects? Is a workaround is even possible?


that type of project is not supported as of this moment, we’ll have to look into it and will try to get you a workaround.

Hi John,

Here’s a workaround, but not the prettiest one. Just create a dummy (empty) C++ project and right click on it to select Nsight user properties, and choose to launch an external application (your exe from VB.NET) and set your working directory, etc.

We will look to see if we can add the support for VB.NET projects in the future.


Thanks for the workaround. I will try to get this up and running.

I’m trying to get up and running in a VB.NET project with NSight 5.2 in VS2015 and CUDA 8.

Everything installs ok, but even with the current versions of everything, the project context menu for my VB.NET project excludes the NSight User Settings menu item, so I’m stuck.

When I add a C# project to the same solution, I can see the NSight User Settings menu item in the context menu of that C# project.

So it looks to me like NSight still doesn’t support VB.NET at all.

Is that correct, or did NVIDIA ever provide a way to use NSight in VB.NET?

Or did you guys ever find a good workaround to use NSight with a VB.NET project?

Hi cayman,

Please try the workaround that rafi brought.