Vbv-size on nvv4l2vp8enc ignores bitrate


I have made some tests to see how well encoders work on a specified bitrate.


OS: L4T 32.3.1
DS: 4.0.1


Here’s the result.

As you can see, it works as expected until each encoder reaches to its limitation.

Now, here’s another test with vbv-size=1 on the same test matrix.

As seen, each limitation is the biggest factor. Not much effect can be seen here.

But please take a look at those results of VP8, which look very difference from the previous ones. It looks like using vbv-size makes an vp8 encoder ignore the bitrate.

Is this a bug or an expected behavior?


vbv-size=1 is not a correct setting for v4l2 plugins. Please set the value to bitrate/fps and check again. For example, in 4Mbps 30fps, please try vbv-size=133333.

We have wrong description in gstreamer user guide. Will correct it.