vectorAddDrv compiles but run fails mac osx 10.9.4

To test my CUDA installation on Mac OSX 10.9.4 retina macbook pro 15", as per instructions on on http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-mac-os-x/, I ran

“make -C 01_Simple/vectorAddDrv” in “/Developer/NVIDIA/CUDA-6.5/samples”

It compiled with a warning, but worked:

/Developer/NVIDIA/CUDA-6.5/bin/nvcc -ccbin clang -m64 -Xcompiler -arch -Xcompiler x86_64 -Xlinker -rpath -Xlinker /Developer/NVIDIA/CUDA-6.5/lib -Xlinker -framework -Xlinker CUDA -gencode arch=compute_11,code=compute_11 -o vectorAddDrv vectorAddDrv.o
nvcc warning : The ‘compute_11’, ‘compute_12’, ‘compute_13’, ‘sm_11’, ‘sm_12’, and ‘sm_13’ architectures are deprecated, and may be removed in a future release.
mkdir -p …/…/bin/x86_64/darwin/release

However, when I ran the binary:

./bin/x86_64/darwin/release/vectorAddDrv

I got the following error:

Vector Addition (Driver API)

Using Device 0: “GeForce GT 750M” with Compute 3.0 capability
findModulePath file not found: <vectorAdd_kernel64.ptx>
findModulePath file not found: <vectorAdd_kernel.cubin>
findModulePath could not find ptx or cubin
Function call failed
FAILED

I tried removing and reinstalling, but the error was reproduced. Any pointers in the right direction would be encouraged. The other three recommended tests on http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-mac-os-x/ worked fine. I can post their output if necessary.

The way in which the SDK looks for the ptx files is kind of convoluted and error-prone.
Go in the bin/x86_64/darwin/release directory and check if the vectorAdd_kernel64.ptx file is present.
If it is there, run from inside the directory ( ./vectorAddDrv ) and it will work.

If you are a beginner, I would ignore all the driver API examples and focus on the runtime API ones.

vectorAdd_kernel64.ptx was present, and running from inside the directory worked.

Thanks!