Verifying CUDA Install

Hi all,

I’m trying to make sure that everything is in place to get started with using CUDA but I’m worried that this is not the case. (Aside: I’m running Windows 7 32-bit) I downloaded the CUDA 2.0 32-bit SDK and installed it. That went fine except that after extracting the files to C:/CUDA the installer window disappears but leaves the icon on the taskbar, requiring task manager to kill it. I also tried to run the CUDA 2.0 drivers but on startup the installer claims that no applicable hardware is available (I have a GTX 470 installed correctly.) So I downloaded the 2.0 SDK examples and many of these run fine from the browser except that Bandwidth Test produces this error:

bandwidthTest.exe - Entry Point Not Found

The procedure entry point cudaHostAlloc could not be located in the dynamic link library cudart.dll

Also I’ve tried running some simple pieces of code with Visual Studio but I get an error saying that cuda.h cannot be found, which I can’t blame VS for because I can’t find cuda.h with the search function either.

Any help on getting these kinks worked out would be much appreciated!


Did you also install the CUDA Toolkit? You need to install both – the toolkit provides header files, common libraries, and compiler tools, while the SDK is more or less a collection of examples and other information.

Usually, you’ll want to install drivers, CUDA Toolkit, then CUDA SDK, in that order.

Also, the CUDA 2.0 SDK is really old (literally a few years out of date). The current stable release is CUDA 3.2, and the CUDA 4.0 tools should be available soon. You should definitely be using one of these versions, as there have been some significant improvements in the tooling since CUDA 2.0.