Very odd GPU timing

Running the latest Jetpack on my Jetson Xavier AGX development system, in MAXN power mode. Timing a kernel using both Cuda events and std::chrono, which are consistent with each other. When I run my app directly on the Jetson using an Ubuntu bash window I get timing results that are reasonable and also consistent with what the profiler reports. When I run the exact same thing using a MobaXterm connection, the times are always longer by about 10x. That’s the really odd part. I also notice when I run the profiler that the GPU clock rate, and therefore the reported duration, can be quite variable.

Why would the exact same run from MobaXterm be 10x slower?

Is there a way to force the clock to be the max 1.377 GHz for the run?

You can run sudo jetson_clocks to enable GPU engine at maximum clock. And can run sudo tegrastats to get status of hardware engines.

Thanks, that seems to answer both my questions. Was driving me crazy.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.