Very poor jetson support

I have two issues with my few days old jetson tk1.

I have ubuntu 14.04 on it (came with the board) and I also installed most recent drivers. Ubuntu tells me that nvidia or any proprietary driver is not installed and it is using xorg driver. What could be the reason for that? When I play a video I see a green ghost. I installed VLC that plays the video but it is jerky. How can I resolve this issue?

I tried my best to download CUDA 6.0 Toolkit for L4T Rel -19.2 and opcv support from https://developer.nvidia.com/jetson-tk1-support but failed. I am already registered and logged in but that stupid webpage ask me register again and proceed. When I do that I go into same loop again. Is there an alternative link for download CUDA and open CV?

How can I boot this from sdcard?

thanks

The Tegra driver versions are different than the GeForce driver versions which explains the confusion that Ubuntu’s driver application (Jockey) is experiencing. If you have a display working, you’re using the Tegra driver.

The VLC playback issues are because the Tegra supports (I believe) OpenMAX hardware video decoding and acceleration, as is typical for mobile devices and is the standard on platforms like Android, etc. VLC may not interface with OMX yet. I am not sure which desktop video players have OMX backends. This is an area that is a bit immature at this time.

Thanks jwcalla. My 1080p monitor works fine. There is no issue visiting webpages in firefox or chrome. Youtube also works fine. (I am not able to install flashpalyer therefore some online videos do not play) My mp4 files play but there is a green ghost. Audio is coming out fine from HDMI. What may be reason for ghost. How can I get rid of that? Thanks.

Any solution to my video issue please? I am getting ghosts.

It’s a problem with the video player. Is that Totem Movie Player you’re using?

I don’t have one of these dev boards yet so I can’t recommend a good video player at this time. If I can get one of these boards I’ll try to get it working with XBMC or one of the mplayer branches.

I’ve got an issue too with some funky color playback. Don’t have any of the green, but plenty of the purple-pink. Try VLC. That’s my next try. VLC solves all my problems usually!

VLC has openmax support
But ubuntu packages don’t enable this feature default.

Hi mtiqbal,

This is a known issue with Totem and the latest release 19.3 will have a fix for this.
VLC is not accelerated yet so jerky video/low performance is expected.

Thanks,
Rahool

The Wiki page http://elinux.org/Tegra/Downstream_SW/Linux4Tegra mentions a solution that one person found to the green videos in Totem problem. Also there is a “Web browsers” page linked from that page that mentions how to get Flash videos (eg: youtube) working on the board too.