Very(!) slow ramp down from high to low clock speeds leading to a significantly increased power cons

Just a sidenote:
funny enough, using the new render offload feature, the nvidia gpu is throttling down nearly instantly.

Hi Eneen,

As per comment #133, you observed ramp down in 3 secs with windows drivers, so I am looking for exact repro steps and config setup done at your end so that we can try to replicate internally.

You can follow below tech link to capture Event logs.

Also please send us dispdiag-nvidia.dat file, you can follow below link for the same.

https://nvidia.custhelp.com/app/answers/detail/a_id/3468/~/how-to-save-a-dispdiag-log-file

Hi All,

I am looking for exact repro steps and config setup done at your end on Windows platform where you observed ramp down in 3 secs so that we can try to replicate internally.

Please also provide event logs and dispdiag-nvidia.dat file.

https://nvidia.custhelp.com/app/answers/detail/a_id/3468/~/how-to-save-a-dispdiag-log-file

Hi All,

I am looking for exact repro steps and config setup done at your end on Windows platform where you observed ramp down in 3 secs so that we can try to replicate internally.

Please also provide event logs and dispdiag-nvidia.dat file.

https://nvidia.custhelp.com/app/answers/detail/a_id/3468/~/how-to-save-a-dispdiag-log-file

Hi All,

I am looking for exact repro steps and config setup done at your end on Windows platform where you observed ramp down in 3 secs so that we can try to replicate internally.

Please also provide event logs and dispdiag-nvidia.dat file.

https://nvidia.custhelp.com/app/answers/detail/a_id/3468/~/how-to-save-a-dispdiag-log-file

Hi @amrits,

Ok here we go.

  1. Dowload:
  • GPU-Z
  • Blender 2.8
  1. Install or just extract blender
  2. Run GPU-Z and switch to sensors tab, it’s as window on top as default
  3. Observe clocks, wait until they are “low”, with fresh windows it should be instant
  4. Invoke start menu by pressing winkey couple of times
  5. Observe clocks again, they should rise for about 3 seconds and go down again
  6. Run blender.
  7. Use shift+MMB and drag to pan scene
  8. Stop panning and observe clocks. They should go down instantly

I’ve cleaned windows app log and it shows nothing during this test.
dispdiag-nvidia.zip (18 KB)

you always talk about the time it takes for clocks to return to their idle state, but what is the reason that clocks turn into high performance when you watch a video or when you use chrome with one tab?

this behavior does not occur in windows and in linux this behavior occurs with many applications
no desktop application mentioned here requires all the power of a 980.

if you can’t fix it, you can give the option to force idle mode within nvidia-settings

It does. Windows drivers just revert to lower clocks a lot faster. You can force idle mode by using a workaround posted in the original post. It still works. Unfortunately it changes the driver state, so in order to return to the usual behaviour you’ll either have to reboot, or init 3rmmod nvidia driversinit 5.

thank you, I know that option with NVreg_RegistryDwords, I have tested it and I think that’s how it should work for desktop tasks.
the problem is you need to restart to play a game, and I think that is not the solution

Thanks all. According to the RELEASE HIGHLIGHTS of the driver at https://www.nvidia.com/Download/driverResults.aspx/153226/

  • Changed GPU clock management strategy to more quickly ramp down clocks after a drop in GPU utilization.

Also, Did you test any nvidia Turing GPU for this ramp down issue?

This is a driver issue, not a GPU architecture issue.

please, don’t ignore the problem of high clocks just for desktop tasks

would it be necessary to open a new thread?

I was very excited to try this new driver but… it’s still the same for me. lol
I think I just should accept that this is how nvidia gpus work on linux… The first post is from 04/07/2017 and it’s still an ongoing issue for many users.

I’d expect a more authoritative answer than “According to the RELEASE HIGHLIGHTS”.
“According to the RELEASE HIGHLIGHTS” is something one expects to be said by anyone in the internet, not by an nvidia employee on the official forum.
What exactly has been changed in the driver for you to “hope” it has been (magically) solved?
Why the windows driver just works and the linux one does not?
Have you read all of the posts?
Need some help? Don’t waste our time by asking your users for support, but ask windows nvidia developers how to solve the issue or at least give nouveau devs the chance to help you.
You’ve several options, pick one or this isn’t going anywere.

I’m done and i’m going to unsubscribe from this pointless thread.

We improved ramp down time in some cases with __GL_ExperimentalPerfStrategy=1 which solution already added in the driver. RELEASE HIGHLIGHTS basically pointing to __GL_ExperimentalPerfStrategy solution.

We have been testing different GPUs like Pascal, Volta, and Turning for clock ramp-down time. We observed different ramp-down time depending on different GPU architecture and the applications used/running. So it would be nice if we get testing results for Turning GPUs from your side to confirm some things.

There’s a user whose GTX 1080 spends up to 30 seconds in P0 mode when sudden spikes in usage occur.

He claims the newest drivers don’t fix this issue for him.

@GM2405

Please attach nvidia-bug-report

1 Like

Hello.
I am worried about the duration between the switch of the P0-state and P2.
In Windows it looks like this


In Linux just moving the terminal window leads to what.

In Windows switch from P0 to P2 in 3 sec. In Linux switch from P0 to P2 need more than 30 seconds!!!
I do not know whether the bug report will help you, I will also attached it too.
nvidia-bug-report.log.gz (1.1 MB)

How many monitors do you have?

One 4k Monitor 28" Samsung U28R55 - Specifications