VEYE CS Camera for Jetson NX

Hi,
I am using following mentioned cameras and image given here for Xavier NX :
http://wiki.veye.cc/index.php/VEYE_CS_Camera_for_Jetson_TX2

I am using prebuilt image and DTB for the corresponding camera module with XAVIER NX. We were also able to check that the image and DTB upgrade is successful.
But could not get the desired results i.e. can’t even detect the camera sensors.

I also checked these camera modules with Raspberry-pi and could detect successfully which indicates that camera modules are working properly.

But when I am connecting the same camera modules with NX I am getting an error as follows during start up:
veye327 9-003b: veye327_board_setup: error during i2c read probe (-121)

What’s wrong in this?

hello priyankaraut,

you got probing errors due to the binaries provided by VEYE Imaging. please contact with them for supports.

FYI,
you should setup the working environments as same as VEYE Imaging mentioned;
please apply all the patches from VEYE Imaging to make these modules works.
thanks

Hello Jerry,

Thank you for your reply.
I had set up the the environment as suggested by VEYE imaging i.e. using prebuilt image and DTB as I mentioned above.
HERE: http://wiki.veye.cc/index.php/VEYE_CS_Camera_for_Jetson_TX2

I also checked image and DTB upgrade is successful.
Anything else that I am missing?

With probing error I am also getting “board setup failed” error.

hello priyankaraut,

normally, those errors were related to regulator settings in the sensor driver.
since we had Jetson Partner Supported Cameras, which list the cameras supported by Jetson Camera Partners on the Jetson platform.
please contact with VEYE Imaging to report the failures.
thanks