vGPU (with Q profile ) on Centos 7.x cause Xorg fail to load

Hi,
i’m encountering a strange problem when creating a new virtual machine with a tesla P4 connected with vGPU tecnology.
My enviroment is configured with:

-DELL R740
-NVIDIA TESLA P4
-SSD
-VMWARE ESXI FOR DESKTOP 6.7U3
-HORIZON VIEW 7.10 or 11
-NVIDIA vGPU version 9.2 or 10 (the problem appears with both versions)

I need to configure a pool of linux vm (centos or ubuntu, but centos is preferable) for an High school and the student must connect using horizon view and use a 3d accelerated desktop.
The main problem is referred to the Xorg service that is unable to start after the reconfiguration using the command "nvidia-xconfig"

The error that appears is the following:

I’ve followed this steps to configure the vm:

1-installed from ISO
2-configured the virtual hw

3-launched the following commands

BASIC INSTALL
yum -y update
yum install libappindicator-gtk3
sudo yum -y install gcc-c++
sudo yum -y install kernel-devel-(uname -r) sudo yum -y install kernel-headers-(uname -r)
yum -y groupinstall "GNOME Desktop" "Development Tools"
yum -y install kernel-devel
yum -y install epel-release
yum -y install dkms
Yum -y install mc

SE LINUX
Open the file /etc/selinux/config  
Change option SELINUX to disabled
Restart the machine

BLACKLIST NOVEAU DRIVER

Edit /etc/default/grub. Append the following  to “GRUB_CMDLINE_LINUX”
rd.driver.blacklist=nouveau nouveau.modeset=0

Generate a new grub configuration to include the above changes.
grub2-mkconfig -o /boot/grub2/grub.cfg

Edit/create /etc/modprobe.d/blacklist.conf and append:
blacklist nouveau

Backup your old initramfs and then build a new one
mv /boot/initramfs-(uname -r).img /boot/initramfs-(uname -r)-nouveau.img
dracut /boot/initramfs-(uname -r).img (uname -r)
Reboot

Check if noveau is disabled
/sbin/lsmod | grep nouveau

INSTALL NVIDIA DRIVER
sudo init 3
sudo service gdm stop
chmod +x NVIDIA-Linux-x86_64-xx.xx-grid.run
./NVIDIA-Linux-x86_64-xx.xx-grid.run

say no to automatic configuration to X service during setup (also tried but the problem persist)

reboot

4-after reboot I’ve checked the pci hw of th NVIDIA card

and tried the following commands

nvidia-xconfig --enable-all-gpus --use-display-device=none --busid="PCI:02:02.0"
nvidia-xconfig --enable-all-gpus --separate-x-screens --busid="PCI:02:02.0"

The error is the same when I reboot or launch the startx command.

5-The /etc/Xorg/xorg.conf configuration is the following:

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 430.63

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GRID P4-2Q"
BusID "PCI:02:02.0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

6-In the Xorg.conf I’ve tried to remove all the section leaving only the “Device” active but nothing change, the (EE) no screen found (EE) persist.
Tried mixed configuration leaving also “screen” and “monitor” active but the result is the same

Can anyone help me?
thanks

Already followed this topic

https://gridforums.nvidia.com/default/topic/962/nvidia-virtual-gpu-technology/m60-vgpu-with-xorg-quot-ee-no-devices-detected-quot-/post/3370/#3370