Video issue after R32.1 install & login

I just updated a TX2 to R32.1 and now observe the following behavior after logging in to the Desktop. After a few seconds on the desktop, the display only shows a small subsection of the screen. Video here shows the behavior well:

It’s like the TX2 decides my monitor is actually 60 px x 40px or something ridiculously small. Any idea what’s going on here? The login screen itself is fine – no issues at all there

Hi,

We didn’t see such issue before. Could you provide the sku of your monitor to us?

Also, could you still ssh to device? Could you reproduce this issue and share the dmesg?

dmesg is here :
https://gist.github.com/osterwood/55101a18074dbac1c86b521c229806df
https://gist.github.com/osterwood/41126f0893dd28c59fd9e8db46b8101f

First one is from boot to post-login where it zoomed in. Second one is just waking the machine up, logging in, and it jumping immediately to the super-zoomed in view.

The LCD is an 11.6" 1920x1080 touchscreen – originally designed for a laptop, but repackaged by Eleduino into a desktop monitor. They don’t make it anymore (I guess the source of panels dried up). I use it with systems from Compulabs running Ubuntu 16.04.6 LTS without any issues.

Looks like the pixel clk is correct in the end of your log.

  1. Could you also try other HDMI display?

  2. Could you provide the EDID of your monitor?

I suspect this issue only happens to specific monitor.

How do I get the EDID? I can hook up to another monitor.

sudo -s

cd /sys/kernel/debug/tegradc.0
cat edid
00 ff ff ff ff ff ff 00 10 ac 4b 40 55 4d 32 41
30 13 01 03 80 35 1e 78 ea 9e b5 a2 59 55 9b 25
0e 50 54 a5 4b 00 71 4f 81 80 d1 c0 01 01 01 01
01 01 01 01 01 01 02 3a 80 18 71 38 2d 40 58 2c
45 00 13 2a 21 00 00 1e 00 00 00 ff 00 55 33 33
34 4b 39 42 52 41 32 4d 55 0a 00 00 00 fc 00 44
45 4c 4c 20 47 32 34 31 30 0a 20 20 00 00 00 fd
00 38 4c 1e 53 11 00 0a 20 20 20 20 20 20 00 17

I just tried the TX2 with a Del G2410t – and the exact same thing happens. The login screen is fine, but once I login it goes to “super zoom mode”. I don’t think the issue is with my monitor – it must be a software configuration issue in my user account.

The bizarre this is this TX2 is fresh. I had installed the initial L4T drivers (R28) and everything was fine. Today I used the SDK Manager to install R32.1 and created this user account after the root filesystem flash and before stalling the rest of the JetPack software (also installed by the SDK Manager). No changes have been made to the user account.

Thanks. I think we need to reproduce this issue on our side too.

Unfortunately, I failed to reproduce this issue on my board + monitor.

Are you using our devkit?

I notice your Del G2410t does not have HDMI port. Do you have any monitor that does not need adapter?

Yes, the TX2 showing this issue is a dev kit unit, no other external devices or components have been installed on the NVIDIA carrier.

I don’t have another HDMI input monitor to test with – they are all DVI input.

I think I’ve managed to solve the problem, I installed “ubuntu-unity-desktop” via aptitude and was able to login and have a normal experience after selecting “Ubuntu” as the Desktop Environment (instead of the default “Unity”) – this is under a dropdown menu in the corner of the password field.

I don’t remember seeing this dropdown menu in the original login box, but it might have been there.

Hi,

That is weird. I will keep this issue in my mind and see if other people also hit it.
Generally we report issue to internal team if we find out the cause, but current situation is still not clear.

It might be useful to see what the driver thinks of the modes and what it actually set. If you can would you add this to the “/etc/xorg.conf” file and reboot and then show the log file ("/var/log/Xorg.0.log"). Edit ‘Section “Device”’ and add this:

Option      "ModeDebug"

This might not show anything new, but it might also offer a clue.