I’m trying to use the Jetson Tegra K1’s hardware play video for h264 with gstreamer.
I want video window is fix, use videosink

nvgstplayer-1.0 -i
=> it is ok

nvgstplayer-1.0 -i --svs=“nvhdmioverlaysink”
=> video window is fix, it is ok

(3.) I want to change video window size
nvgstplayer-1.0 -i --svs=“nvhdmioverlaysink” --window-x=300 –window-y=300 –window-width=480 –window-height=270
=> result is the same with (2.), why ?

help me !

I too try different method

filesrc location= “”
! qtdemux
! h264parse
! queue
! omxh264dec
! nvhdmioverlaysink

=> it is not error, but how is change video window size ?

thanks !
Mark Pei

Hi Mark,

Could you try the following command?

gst-launch-1.0  filesrc location= "" !  qtdemux !  h264parse ! queue ! omxh264dec ! videoscale ! video/x-raw, width=480,height=270 ! nvhdmioverlaysink


Hi Mark,

As “nvgstplayer-1.0 --help” clearly mention that “–window-” options are for “non overlay rendering” only.

Please try following gstreamer-0.10 pipeline in case wish to change hdmi overlay video window size.

gst-launch-0.10 filesrc location=rat60sec_h264_1080_30_20M.mp4 ! qtdemux name=mux ! nv_omx_h264dec ! nv_omx_hdmi_videosink overlay_x=300 overlay_y=300 overlay_w=480 overlay_h=270 -e

“nvhdmioverlaysink” is currently not supporting changing overlay window size with gstreamer-1.0.

Amit Pandya