Visionworks demos and samples cause cudaGraphicsGLRegisterBuffer CUDA error


I’m trying to run the demos and samples that come with visionworks.

This is the CUDA error that is printed when I run any of the Visionworks examples:

Error: CUDA Error in cudaGraphicsGLRegisterBuffer(&resStyles_, vboStyles_,
file 1106 line : invalid device ordinal

Here’s the configuration:

VisionWorks library info:
	 VisionWorks version : 1.5.3
	 OpenVX Standard version : 1.1.0
$ nvidia-debugdump -l
Found 3 NVIDIA devices
	Device ID:              0
	Device name:            Quadro K4200   (*PrimaryCard)
	GPU internal ID:        GPU-155a3bdd-93f4-e81a-246d-838d03c95e66

	Device ID:              1
	Device name:            Quadro K4200
	GPU internal ID:        GPU-a1c7ca11-f9bf-4e0d-09f0-5106b7a7c932

	Device ID:              2
	Device name:            Tesla K20c
	GPU internal ID:        0324813082841
$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.1 LTS
Release:	16.04
Codename:	xenial

I originally installed everything using the JetPack 2.3.1 installer. Then I tried to fix this problem by upgrading CUDA to 8.0.44, which had no effect.

I was able to run an older version of the visionworks examples on the same hardware.

Thanks for you help!