Visionworks is not installed (For Google project Tango)

I am working on project Tango development using Tegra.
I have a question about nvidia extension of ​​OpenVX and how to run it on Google project Tango.
As of my understanding cuda 7 is not supported for TK1, and cuda > 6.0 is not enabled in Tango dev kit. I was developing for it using TADP 3.0r4 to enable cuda.
I was wondering how I can use VisonWorks (on host) for cross development. Is the current release supported for Tango? I tried to install it through the newest Jetpack (TK1) but VisionWorks installation keeps saying:
The following packages have unmet dependencies:
libvisionworks : Depends: cuda-cudart-7-0 but it is not installable
Is it supposed to only work on Jetson TK1/TX1?

I’d appreciate your help to figure out how these things work.


Hamid since 6 months have passed, did you find any answer to this question? I am getting the same error message as you while setting up visionworks on TK1. As per my understanding, CUDA 7 is not supported on TK1. However to setup visionworks I am installing cuda 7 on host machine so I can compile visionworks properly. Do you have any idea if this will be of any use?