Visual Studio 2010, NVIDIA AndroidWorks and some questions about debugging Android Apps

Hi,
I have a Visual Studio 2010 Professional.Ive installed NVIDIA AndroidWorks.I have a tablet with Android 4.1.1 also.Ive been tried to debug simple android NDK application in Visual Studio 2010 Professional on my device, but I received some error ‘Failed to attach: Android 4.1(API level 16) devices are not currently supported’.
Сan I somehow solve this problem or debugger really currently does not support Android 4.1 device?If not supported, are there plans for this in future versions NVIDIA AndroidWorks?I do not have the ability to upgrade the operating system on my tablet.

Hi,

There is a bug pertaining to API level 16 devices that makes debugging native code on them impossible. We’ve decided to fail earlier with an error message instead of letting people get to the buggy behavior.

So, unfortunately, you can’t debug on a Android 4.1 device. As a workaround, you could try downgrading the device to API level 15 or installing a custom firmware (such as CyanogenMod) that is based on a later API level than 16.

Thank you very much for your reply.Then the question becomes, if the operation is supported with the device emulator on Android on x86(Genymotion)

We haven’t tried Genymotion, but in theory it should work since we support debugging with Google’s SDK emulators (ARM, AArch64, x86 and x86_64).

I tried using NVIDIA AndroidWorks simplest to debug native application in Genymotion emulator and received the error “Failed to attach: Failed to start debug server on device” and the warning “Cannot launch gdbserver: all options have failed”.Please tell me what am I doing wrong?

Hi. First of all, please upgrade to the latest version of Android Works. If that doesn’t help, when please attach the logs from %AppData%\NVIDIA Corporation\Nsight Tegra\Logs
Also the details about the Android system running on Genymotion emulator would be very helpful.

Hello.I already have the latest version of NVIDIA AndroidWorks.In Genymotion I use the following virtual device Sony Xperia Z - 4.3 - API 18 - 1080x1920.I send you the logs.

Nsight Tegra.log (62.9 KB)

If you require any more data, I will be happy to provide.

Thank you. Please, try the following workaround - add the following permissions



to AndroidManifest.xml of the application package you’re trying to debug (according to the logs, it’s called ‘yu.ty’) and see if it would help.

I was prescribed data lines in the file AndroidManifest.xml but, unfortunately, the situation has not changed.Send you new logs.

Nsight Tegra.log (446 Bytes)

Unfortunately, the new log is very short - it consists only of 5 lines. It would be helpful to archive the entire content of the Logs directory and attach the zip here.

I just deleted all the logs is thought to be redundant.Here is the log from launch Visual Studio to run the application and the error.And immediately just in case the file AndroidManifest.xml.
AndroidManifest.xml (1.52 KB)

Nsight Tegra.log (67.9 KB)

Thanks for additional information, we will look on this.