Visual Studio button missing - Omniverse Code

I am quite new to Omniverse, in a lot of tutorials I see about creating extensions, the dedicated “Visual Studio” button is used in the extension’s description to open the project in VS.

This button does not seem to exist for me. Are there any steps necessary to set up VS with Omniverse Code to make this button appear?

Looking for this one:


While on my end, it is just this:
image

I have VS 2019 is installed. Also, VS does not open automatically after creating a new extension. Related?

Hi @moebelhaus. That button launches “Visual Studio Code”. You’ll need it installed on your system to see that button. Both issues are related.

I do have VS 2019 installed though. Any setting that needs to be flipped to make Omniverse aware of the VS install?

Just to be clear, this is the editor that’s required: https://code.visualstudio.com/. Our developer workflows are specifically tailored towards VSCode right now. We are evaluating supporting other editors or allowing developers to specify their preferred editor. Some parts already respect the $EDITOR variable, but you’re going to have the best out-of-the-box experience with VSCode.

Got it now, I misread your previous answer at first. Thanks a bunch!

1 Like

Correction, even though VSCode is installed, that dedicated VSCode-button does not show up. Opening the extension in VSCode via the one button I have there, opens the .toml only.

Once I open the extension folder manually in VSCode, I got access to the whole extension structure, however VSCode does not seem to know about ani of the omni modules.

How can I open an extension’s source code in VSCode so that Intellisense will autocomplete, jump to definitions etc.? In some tutorials, it looks like this should be the possible.