Visual Studio Integration 9.0 fail to install after removing CUDA 9.1

Hi,

I have Visual Studio 2017.
I had CUDA-9.1 but uninstall it using the uninstall setting panel.
I installed CUDA-9.0 and tensorflow-gpu is working.
However, Visual Studio Integration 9.0 fail and therefor I am not able to compile deviceQuery_vs2017.sln.

When installing CUDA-9.0 I am forced to uncheck Visual Studio Integration otherwise the installation fail.
After successfully installed CUDA, I relaunch the installer and ONLY checked the integration bits but it fails still.
I looked online and saw things about NSigh so I downloaded NSight-5.3 at https://developer.nvidia.com/nsight-visual-studio-edition-5_3 and installed that but that didnt solved the problem.

When I open Visual Studio I get:

The 'Nvda.Vsip.NvdaPAckage, Nvda.Vsip.Net, Version=5.4.0.17229, ....' package did not load correctly.

I ignore this message and continue.
When compiling I get:

MSB4019	
The imported project "C:\Program Files (x86)\Microsoft Visual Studio017\Community\Common7\IDE\VC\VCTargets\BuildCustomizations\CUDA 9.0.props" was not found. 
Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.	
C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0_Utilities\deviceQuery\deviceQuery_vs2017.vcxproj	37

Any idea what’s going on ?

anyone ? up :)

Same problem! Still googling…

Finally… clean install Windows… all works! CUDA 9.1.85, VS 2017 15.6.7 …=)

haha I don’t really want to have to reinstall my OS for that.

I reinstalled windows and got nothing. Still doesn’t work. WHAT THE FUCK. GTX 1060, up to date drivers. What a joke.

I wrote an article, maybe that can help you? http://leobenkel.com/2018/04/tensorflow-gpu-windows10-tutorial/

My sequence was:

  1. reinstall completely clean Windows 10 (i’ve tried both Pro and Home).
  2. got all windows updates
  3. reboot
  4. NO NVidia fresh drivers at first time!
  5. Then VS most fresh Community with only 2017 and 2015 toolchains
  6. Then CUDA (latest)
  7. Then CUDA Patches

everything is okay…

Do You still have CUDA installation fail?

P.S. 2017 tools are still unsupported, and you may have error with 2015 tools like:
nvcc fatal: cl in PATH is not the same…etc., so in this case just add …\Microsoft Visual Studio 14.0\VC\bin\x86_64 in PATH

Neither option worked. I must say this has been one of the most frustrating installs I’ve experienced in my many years of troubleshooting. Some solutions work for some people, but there just is something that isn’t right with this program. Fresh install, fresh everything. Nothing works.

dredile, wish I could help… do you roll back windows by its recover tool or from usb?