VLC crashes when opening mp4 video created by GST locally

Anyone encounters the problem with VLC? The VLC player crashes if I let it open a gst-launch output (mp4 video). The video plays okay in other tools, such as the build-in video player on TX2.

I removed and re-installed the VLC, still no luck. The VLC version stays 2.2.2. I know the latest version should be 3 something. But the Ubuntu Software manager seems only get that far. Besides, I’m not sure if a newer version would help or not.

The gst-launch is a basic one, like:
gst-launch-1.0 -e nvcamerasrc sensor-id=0 ! ‘video/x-raw(memory:NVMM), format=(string)I420, width=(int)640, height=(int)480’ ! omxh264enc ! ‘video/x-h264, streamformat=(string)byte-stream’ ! h264parse ! qtmux ! filesink location=test.mp4

Also tried on cvlc. The error message I got from running cvlc was

$ cvlc test.mp4

VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[000000000052a290] dummy interface: using the dummy interface module...
Bus error (core dumped)

By the way, the issue of having the video+audio play in web browser has been resolved. See follow up in
https://devtalk.nvidia.com/default/topic/1032516/how-to-create-mp4-video-playable-on-web-browser-/?offset=13#5254896

Perhaps allow me to pursue it from a different angle, why don’t I upgrade the VLC and see if it helps.

The question is, how do I get VLC 3.0 (or whatever the revision suitable to TX2)? I removed and reinstalled VLC, still got 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80).

Hi tmx3,
Can you play it with gstreamer pipeline?

@DaneLLL, yes, the pipeline works. I can sink the pipeline to screen display by nveglglessink, or xvimagesink. Plus, the filesink output can be played by TX2’s build-in video player (by clicking on the file from File Manager). But if I loaded the video using VLC’s “local file”, VLC crashed in my TX2. Or if I uploaded the mp4 to a web server and tried to play the video using VLC’s “network stream”, it wouldn’t work either.
For debugging, here is a link to my TX2 generated mp4: http://www.jmrcubed.com/cdn_v07/sdb/demo/mp4av/1cam_av.mp4

We don’t have experience in running VLC but other users share information in below thread.
Please refer to https://devtalk.nvidia.com/default/topic/990198/