VPI-0.4 rescale prefermence Test On CUDA

Hello, I have 2 questions regarding both environment and performance test.

Firstly, I use VPI-0.4 to test the perfermence of rescale which is your latest release version, the test used CUDA result is nearly 10 times worse than claims, how Can I get better prefermence data?
I have already maximized the device performance first, with those two commands.

Secondly, I’m using VPI-0.4 and run the sample 04 — rescale on Jetson Xavier, but it seems that I can only run it with monitor instead of logging ssh remote terminal? Is there anyone know how to fix this bug? Thanks very much.

image

Hi,

1.
Could you try our script to maximize the performance?

2.
Please try the below command and rerun the sample.

$ export DISPLAY=:0

Thanks.

I’ve tried it before, but it seems that it only works with ordinary user instead of root user. How could I make it work for root user? Thanks.

And it seems that we need to use source command to save this config to the system file? Do you know which filepath I need to add to the source ### ? I tried source /etc/profile and source ~/.bashrc, both not work when I open another ssh terminal. We still need to export every time we open a new terminal. How could I fix that?

Hi,

The 04-rescale example doesn’t require a DISPLAY connected.
We can run it directly with root and without exporting the DISPLAY parameter.

Could you give it a try?
Ex.

$ ./vpi_sample_04_rescale cuda ../assets/kodim08.png

Thanks.

Hello, I tried this several times already. It does not work.

Okay. Thanks.

We cannot reproduce this in our environment.
Do you install Xavier with JetPack4.4.1?

Yes, JetPack4.4.1

Thanks. Let me check this internally first.
Stay tuned.

Sorry,I upgrade JetPack to 4.4 instead of 4.4.1

Cannot 4.4 support DISPLAY? only 4.4.1 works?

Hi,

JetPack4.4 should use vpi-0.3.
VPI-0.4 needs JetPack4.4.1.

Could you align the package and OS first and try it again?

Thanks.

Ok, I‘ve already upgrade JetPack to 4.4.1 which I quite confirm. However, it still shows the release REVISION is 4.4. I really don’t know why.

And I tried it again to run the vpi-0.4 sample code, it still shows Failed to get EGL display error and dumped when I ssh from remote and execute from the terminal. Can you help me resolve this problem? Thanks!

Is this correct version? Also is this command I used correct? Thanks!

Hi,

JetPack 4.4.1’s OS version is r32.4.4.
We don’t meet a similar issue when reflashing the JetPack4.4.1 from SDKManager directly.

Let us discuss this internally and update more information with you.
Thanks.

Ok,let me know once you have any updates regarding this issue. Pretty thanks!

Hello, AastaLLL
I am trying to run the vpi-0.4 rescale demo, but I get the performance results much slower than claimed in your official documents? Did these results include the time consumption of vpiStreamSync()?
How should I use this vpiSubmitRescale(stream, VPI_BACKEND_CUDA, imageNV12, outputNV12, VPI_INTERP_LINEAR, VPI_BOUNDARY_COND_CLAMP)) in order to make it faster?
I measure API performance like this.


Am I right? Is there any parallelizable methods that I need to use?


Are all the results tested in sample code 04-rescale?

Hi,

Would you mind sharing the performance captured in your environment?
And have you executed the script shared on Dec 9?

You can also find a timing example in the below folder:

/opt/nvidia/vpi-0.4/samples/05-timing/

Thanks.