VPI Host Error

Hello NVIDIA,

I’m currently trying to (re)flash my Jetson Nano using NVIDIA’s SDKManager, but I’m encountering the following error when installing the VPI on Host.

SUMMARY: VPI on Host - host: First Error: Missing dependencies when running apt command. There are missing dependencies in apt-get database. Try 'apt-get -f install' with no packages (or specify a solution) in a terminal, and click RETRY.

I’ve read a bit further above in NVIDIA’s logs, and the error seems to stem from python-vpi1 : Depends: python2.7-numpy but it is not installable. I’ve tried installing python2.7-numpy manually using pip, but it has not fixed the issue.

I’ve attached the exported logs below.

SDKM_logs_JetPack_4.6.2_Linux_2022-07-18_15-30-29.zip (265.2 KB)

Hi,

Could you try if you can install VPI with the instructions below:

https://docs.nvidia.com/vpi/1.2/installation.html

Thanks.

Hi, I’ve just run all of the commands corresponding to Ubuntu-18.04. However, I’m getting the exact same error message.

If it helps, my OS has Ubuntu22.04 since I’m unable to install an earlier Ubuntu version without my system auto-upgrading to 22.04, and I’m using the workaround outlined here in order to get SDKManager to work (I “backdate” to Ubuntu18.04 in the workaround).

Here is the exported log file

SDKM_logs_JetPack_4.6.2_Linux_2022-07-19_13-30-59.zip (66.8 KB)

EDIT: I ran sudo apt-get install libnvvpi1 to check the VPI version, and I received the following response. Is it an issue with the version being “too new”?

libnvvpi1 is already the newest version (1.2.3).

Hi,

Thanks for the platform information.

We are checking with our internal team.
Will share more information with you later.

1 Like

Update: I’ve uninstalled Ubuntu 22.04 and re-installed Ubuntu 18.04 on my OS, and the error no longer occurs, and I’ve been able to flash my Jetson successfully. I guess workarounds can’t be perfect X).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.