VPI1 Stereo Disparity - Confidence map is too high


I am having hard times with the VPI 1.X stereo disparity sample on my Jetson Nano B01. I made some virtual benchmark images :

Virtual cameras are perfectly aligned, with a subtle amount of grain to seem more realistic.
As a result with CUDA backend, I get this disparity map:

And this confidence map:

I have a few questions about this output:

  • What is this black rectangle on the top-loft corner? It doesn’t show up with CPU backend.
  • Why is the confidence so high in the sky?

I read this topic with a similar issue, but I cannot use the uniqueness parameter, as I am stuck with VPI1 / JetPack 4.6 on my Jetson Nano B01.

I am afraid that the confidence value just takes the correlation score into consideration.
What do you advise to get a usable confidence map ?

Thank you in advance.

Jetson Nano B01 4GB (eMMC 16GB)
Ubuntu 18.04
JetPack 4.6 (L4T 32.6.1)
CUDA 10.2.3
VPI 1.1.15


Have you tried tuning the parameter or downscaling the images to see if it helps?


Thank you for this quick reply.
I managed to change the confidenceThreshold parameter to its maximum (65280). It is slightly better, but doesn’t seem to solve the problem.

Downscaling is not available with CUDA backend : VPI_ERROR_INVALID_ARGUMENT: Only downscale factor of 1 is supported
I you meant manually reduce input size, it doesn’t change anything except the size of the black rectangle on the top-left:

By the way, this rectangle is probably due to the way I apply grain, since it doesn’t show up when I use real images. I’ll try to investigate this.



Rescale can help you to downsample an image:

The suggestion is from some of our users found the VPI stereo matching perform better in the low-resolution image.
So it’s recommended to give it a try.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.