VQSR (applyVQSR) not doing any filtering

The vqsr module of parabricks v3.7 exits with the following message:

-------ApplyVQSR-------

[PB Error 2022-Mar-08 11:13:56][src/ApplyVQSR.cpp:247] Keeping all variants with VQSLOD >= 0.0, exiting.

I don’t understand what the error is. Both the recal and the tranches file were created and seems to be ok.

The command line is the same as for the QuickStart example.

Best regards
Harald

Hey @harald.gro,

Just to clarify, you used the sample data to run this? So your commands look exactly like the QuickStart example below?

$ pbrun vqsr \
    --in-vcf sample.vcf \
    --out-vcf output.vcf
    --out-recal output.recal \
    --out-tranches output.tranches \
    --resource omni,known=false,training=true,truth=true,prior=12.0:1000G_omni2.5.hg38.vcf \
    --annotation QD \
    --annotation MQ \
    --annotation MQRankSum \
    -annotation ReadPosRankSum

Sorry, no. The input data was from my own WGS dataset. The rest of the command was the same.

Edit: I also tried running the compatible gatk ApplyVQSR (docker v4.2.5.0) command and that worked without any issues (after creating a required index file for the output.recal file).

gatk ApplyVQSR -V sample.vcf \
               --recal-file output.recal \
               --tranches-file output.tranches \
               -O output.vcf \
               --mode BOTH

Hi @harald.gro ,

Can you please let us know :

  • what GPUs you are using
  • the output of pbrun --version
  • the command line you used

Thanks

pbrun --version: pbrun: 3.7.0-1.ampere

Command line:

pbrun vqsr \
        --in-vcf sample_hc.vcf \
        --out-vcf sample_hc.vqsr.vcf \
        --out-recal sample.recal \
        --out-tranches sample.tranches \
        --resource omni,known=false,training=true,truth=true,prior=12.0:1000G_omni2.5.hg38.vcf \
        --annotation QD \
        --annotation MQ \
        --annotation MQRankSum \
        --annotation ReadPosRankSum

These are the GPUs that were provided.

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 450.156.00   Driver Version: 450.156.00   CUDA Version: 11.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  A100-SXM-80GB       On   | 00000000:07:00.0 Off |                    0 |
| N/A   30C    P0    63W / 400W |      0MiB / 81252MiB |      0%      Default |
|                               |                      |             Disabled |
+-------------------------------+----------------------+----------------------+
|   1  A100-SXM-80GB       On   | 00000000:0F:00.0 Off |                    0 |
| N/A   29C    P0    63W / 400W |      0MiB / 81252MiB |      0%      Default |
|                               |                      |             Disabled |
+-------------------------------+----------------------+----------------------+

A small question about the GPU’s. The vqsr app doesn’t mention any options for assigning number of GPUs? Are there anything missing in the documentation?