VRAM Allocation Issues

Interesting. I thought it was just me. Doesn’t seem to be a problem with native games, but definitely is with any dxvk or vkd3d game.

Alt-tabbing in a game or loading a different area causes it to happen faster.

Operating System: Slackware-current (64-bit)
xfce4, 4.18
Kernel Version: 6.6.21
Graphics Platform: X11
Graphics Processor: GeForce GTX 1050ti (4GB vram), 550.54.14

I have a similar issue, but for me mostly the apps will report out of memory (so for RDR2, Doom 2016, stable diffusion and a few others)

2024 and I found to have the same issue with my rtx3050 mobile

±--------------------------------------------------------------------------------------+
| NVIDIA-SMI 535.161.08 Driver Version: 535.161.08 CUDA Version: 12.2 |
|-----------------------------------------±---------------------±---------------------+
| GPU Name Persistence-M | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap | Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|=========================================+======================+======================|
| 0 NVIDIA GeForce RTX 3050 … On | 00000000:01:00.0 Off | N/A |
| N/A 50C P0 17W / 80W | 189MiB / 4096MiB | 5% Default |
| | | N/A |
±----------------------------------------±---------------------±---------------------+

Memory info (GL_NVX_gpu_memory_info):
Dedicated video memory: 4096 MB
Total available memory: 4096 MB
Currently available dedicated video memory: 3696 MB

I get actually crashes in games and and also with stable diffusion (running out of memory)

funnliy when i bought the laptop (ASUS-TUF-Gaming-F17-FX707ZC4), everything ran well with the old 535 driver, but since the last two updates, it is now broken for me.

Hi all.
So same problems…
And Yes this is very annoying this missing option to be able to Enable or Disable the memory RAM / VRAM sharing
under linux. Please Nvidia force this option on Linux to be always activated on linux at the the build levels of the drivers and the option became Checkable on the nvidia-settings Gui or in the nvidia-smi utils like on windows.
Thanks again.

Mmh I noticed odd memory allocation behavior too. Vkd3d falls back to system memory even if I have plenty of vram. I’m not sure if it’s a driver, vkd3d or game issue.
This is with rebar enabled

This is such a major issue. Is this ever going to get fixed? I’m running the latest 550 driver, and this is still an issue. I’ve tested games in Windows and run them at max settings; the game is using maximum vram usage spilling over into system RAM, and I never get framedrops like what I get under Linux, games where I easily get 60 fps on Windows. Even with max vram usage is dropping into the single digits on Linux when vram is maxed, you might get some micro stuttering in Windows but never ever single digit fps.

Its not just gaming. If I have many application windows open dedicated memory usage increases up to total available dedicated memory and there is overall desktop performance penalty, like windows compositing feels sluggish. Under such conditions there is also CUDA_ERROR_OUT_OF_MEMORY when playing 4K HDR video using mpv player with hwdec=nvdec, which plays just fine when I close some browser windows and electron apps.
I have optimus laptop and this is definitely nvidia driver releated becouse with intel integrated GPU issues do not arise.
nvidia-bug-report.log.gz (1.8 MB)

2 Likes