VRWorks 360 Video stitch_sample_app crashes

Dear Community,

I am using the VrWorks sdk => VRWorks 360 Video Beta SDK V0.9.0
I have followed all the instructions, compiled and ran stitch_sample_app.exe

The application crashes in runStitcher() method when it calls NVVS_StitcherFeedInput() method (in stitch_sample_app.cpp). As this method is defined in the dll, I could not debug the code.

I have not changed the code, I have compiled and run as it is. No command line arguments are passed as it takes default parameters. The dataset in SDK is used by default and I can see in logs

Can anyone help me in fixing this issue?

My System details:
Hardware:GeForce GTX TITAN X and GeForce GTX 1050 Ti
NVIDIA graphics Driver version: 378.xx

Software: Windows 10, Cmake 3.8.1, Microsoft Visual Studio 2015


I have the same issue. The program actually throws the following:

Exception thrown at 0x0000000000000000 in stitch_sample_app.exe: 0xC0000005: Access violation executing location 0x0000000000000000.

exactly when calling NVVS_StitcherFeedInput()

Tested on GeForce 840m, GeForce GTX 750 Ti

Are you using any command line arguments?
Did you build the demo codebase as instructed in the README.txt under the demo folder?

No, I didn’t specify any command line argument. According to README.txt application will use default arguments if they are not provided. view_3_camera_aerial works fine, but stitch_sample_app.exe doesn’t, neither prebuilt nor built on my PC. I did everything according to README, created VS solution using cmake, and built if from Visual Studio. But I used VS 2017 compilers.

Maybe using VS2017 is causing the problem, the documentation mentions VS2015 and it’s working fine for me with VS2015. You’re right that stitch_sample_app should work without arguments too.
If the prebuilt .exe is not working either, then the issue might not be using VS2017, the prebuilt .exe doesn’t output anything unless arguments like -o or -display are used. What exactly happens when you run the prebuilt .exe?

Through the Windows Event Viewer I’ve found out that when running stitch_sample_app (doesn’t matter prebuilt or not) with the argument “-display” I get the following error

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="nvlddmkm" /> 
  <EventID Qualifiers="49322">13</EventID> 
  <TimeCreated SystemTime="2017-07-06T18:40:32.249037800Z" /> 
  <Security /> 
- <EventData>
  <Data>Graphics Exception: ESR 0x505648=0x1000e 0x505650=0x4 0x505644=0xd3eff2 0x50564c=0x7f</Data> 

But without any argument I get

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <TimeCreated SystemTime="2017-07-06T18:26:04.760870500Z" /> 
  <Security /> 
- <EventData>
  <Data>c:\Users\Yury\Downloads\VRWorks 360 Video Beta SDK V0.9.1\demo\bin\stitch_sample_app.exe</Data> 
  <Data /> 
  <Data /> 

Not sure if I can figure out anything useful from the logs. I’ve never used the event viewer so if you tell me how, I can show you my logs for comparison if you think that would help.

You should make sure that your GPU driver version is 375.86 or later. What OS are you using? I think the prebuilt .exe should work flawlessly unless there is something wrong with your system. Have you tried this on another laptop/pc?

The only time I’ve had issues with NVVS_StitcherFeedInput() is when I didn’t have the footage files in the right location or the footage video codec was wrong.

Driver version is 382.53, I’m using Windows 10 x64. The Event Viewer is located at “Control Panel\System and Security\Administrative Tools”. Log about a crash can be found in the Error list. Now I’m using my laptop with GeForce 840m, but I also checked the demo on the PC with the same OS and driver version but with GeForce GTX 750 Ti. But on that PC I tested only prebuilt binaries. I can compile the demo there and check what will happen. Also the demo was tested (but not by me) on the PC with GeForce GTX 1050, and it works fine out of the box. But I can’t find out the key difference which causes error on my laptop but not on that.

I don’t face any crashes while running the demo so I don’t think the event viewer log will be of any use.

Hope you found a solution.

Eventually, VR Works 360 demos have started working on my desktop PC with GeForce GTX 750 Ti. I replaced sources to another drive (which is not a system drive) and recompiled examples (precompiled examples still don’t work). But that didn’t help on my laptop, though now I get a new, more specific error, maybe. If I run “stitcher_sample_app -display”, window with black contents appear, but it immediately closes and application finishes. In event log I get a big list of the identical errors from nvlddmkm:

The description for Event ID 13 from source nvlddmkm cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

Graphics Exception: ESR 0x505648=0x3000e 0x505650=0x4 0x505644=0xd3eff2 0x50564c=0x7f

the message resource is present but the message is not found in the string/message table

May be GeForce 840m is just not supported, but I can’t find any proves of that.

I don’t see why 840m won’t be supported, its compute capability is above 3.5, but I can’t point out another reason for it not working either.