VS Code Doesn't Link For Me Like Your Video

Edit: I solved it. You have to use VS Code’s Rename Symbol instead of just typing over the class name. Should have known this.

Leaving rest of post

I tried to follow “Paul’s build an Omniverse Extension in 10 minutes”, but if I click save in VS Code, my extension doesn’t update and goes away.

Build an Omniverse Extension in less than 10 Minutes | NVIDIA On-Demand

I did change the auto generated class name from MyExtension to something else. Maybe that breaks it?

I tried to follow this tutorial (again). When I create the extension, VS Code opened. The VS Code Link says unattached.

How do you attach, or is that supposed to stay unlinked?

Also, my extension shows some red warning triangle, but I don’t know what the warning is or means. A tool tip or something explaining the error would be nice.

Edit; This was caused by typing over the file without using Rename. Something must reference the Extension name. Sorry to bother everyone.

Edit: I figured out (again) you have to click the Settings icon to manage extensions. Deleting rant below.

Thank you

1 Like