VS2010 spaces in path names

Trying to open new project but get Android tools do not support spaces in paths error.
Tools, Options menu shows all Android paths without spaces.
Any ideas on how to resolve this problem?

is there a space in the project name or the file path of the code you’re trying to compile? unfortunately, this is a gdb limitation.

No spaces in the project name, no spaces in file path, no spaces in relevant environment variables.
Space, the final frontier!


I have checked the message you are talking about. It seems that it can only be produced by spaces in the project’s location.

When you start a project wizard, please ensure that the Location field does not contain any spaces, because it does by default, e.g. in my case it looks like this:

c:\users\dpolyanitsa\documents\visual studio 2010\Projects


I had the same problem. I fixed it by updating the file paths as well as the “Location to store device files:” You can find this setting by navigating to Tools/Options in the main VS toolbar, then click on “Show all settings” to be able to see the android options. The last element in the Android/General tab was empty. I filled in what is shown in the help manual: “%TEMP%\Android” (minus the quotes). I hope this helps.



I have this exact problem and tried everything… I changed all of my paths to non-space (project location, and all paths in Android settings) and even tried reinstalling the damn thing. No luck ATM. I’ve searched through the entire settings looking for absolutely everything, and didn’t find any more paths. Any ideas?

Allright… there’s something I’ve just tried, and worked flawlessly. Visual Studio has an option to save projects on creation. If you enable that feature, the box with the project path will appear, and you’ll be able to change it to eliminate all blanks