vs2017 output window

proud to have successfully integrated custom image analysis calculations using CUDA into our base code.
one library down, six+ to go.

using ManagedCuda to load and run PTX built by C++ project
in DEBUG mode I see a lot of noise in the output window. how do I make it stop?

12/11/2017 10:00:42 AM, cuMemFree: Success
12/11/2017 10:00:42 AM, cuMemFree: Success
12/11/2017 10:00:42 AM, cuMemAlloc: Success
12/11/2017 10:00:42 AM, cuMemcpyHtoD: Success
12/11/2017 10:00:42 AM, cuMemAlloc: Success
12/11/2017 10:00:42 AM, cuMemcpyHtoD: Success
12/11/2017 10:00:42 AM, cuMemAlloc: Success
12/11/2017 10:00:42 AM, cuCtxSynchronize: Success, Kernel: cudaPeak
etc…

This is a characteristic of managedCuda. It’s evident by inspecting any of the managedCuda files, for example:

https://github.com/kunzmi/managedCuda/blob/master/CudaFFT/BasicFFTTypes.cs

and noting lines like this:

Debug.WriteLine(String.Format("{0:G}, {1}: {2}", DateTime.Now, "cufftSetStream", res));

So perhaps one method is to build not in DEBUG mode. Perhaps there are other options if you study the Debug class in managedCuda (which is not an NVIDIA product, nor is it supported by NVIDIA).

thanks for your reply.

my bad. was using debug version of ManagedCuda.dll. don’t really need it.

which is not an NVIDIA product, nor is it supported by NVIDIA).
too bad as that is probably the only way I will be doing CUDA development

thanks again!