VSCode Installation Error

Hi, I’m currently struggling with the vscode installation due to some version issues that i cannot understand.
I downloaded vscode with several ways (git clone, from vscode homepage, wget etc.), but all the methods fail with the following error message:

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 code : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1.6 is installed
        Depends: libgssapi-krb5-2 (>= 1.17) but 1.16-2ubuntu0.4 is installed
        Depends: libxkbfile1 (>= 1:1.1.0) but 1:1.0.9-2 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I’ve tried the suggested solutions and searched to fix this problem but nothing worked for me.
I also read a post that libc6 doesn’t support higher versions than 2.27 in ubuntu 18.04, which is my jetson ubuntu’s version.

Does anyone know how to fix this problem triggered by vscode installation?
I’ll really really appreciate your help!

Do you try build VSCode by yourself?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.