Vulkan driver crashes in vk_icdGetInstanceProcAddr

I’ve been trying to get the Vulkan driver to work on FreeBSD 11.0 x64. I built the 381.22 drivers and the Vulkan loader. Running objdump shows that is what is providing the vk_icdGetInstanceProcAddr entry point. So, I added a file called /usr/local/share/vulkan/icd.d/nvidia_icd.json containing these contents:

    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "",
        "api_version" : "1.0.50"

When I run vulkaninfo, it seems to load the ICD, before crashing right away in a call to vk_icdGetInstanceProcAddr(NULL, “vkCreateInstance”). The stack trace isn’t really useful, unfortunately:

#0  0x0000000000000000 in ?? ()
#1  0x0000000800c93594 in loader_scanned_icd_add (inst=0x0, icd_tramp_list=0x7fffffffe6a0, filename=0x7fffffffe1a0 "", api_version=0x400032)
#2  0x0000000800c91942 in loader_icd_scan (inst=0x0, icd_tramp_list=0x7fffffffe6a0)
#3  0x0000000800c9d796 in vkEnumerateInstanceExtensionProperties (pLayerName=0x0, pPropertyCount=0x7fffffffe730, pProperties=0x0)

I tried both the 381.22 and the 375.66 drivers, with the same effect.

So, what does this mean? Has the Vulkan code just not been enabled for FreeBSD?