Vulkan Samples not running caused by XCB errors

this is the current error,
trying to run any sample, comes with the same error

++ -g 02-enumerate_devices/02-enumerate_devices.cpp -Iutils -I/home/agx/Vulkan-Loader/build/Vulkan-Headers/include -o 02-enumerate_devices.out && clear && ./02-enumerate_devices.out <

In file included from utils/util_init.hpp:24:0,
from 02-enumerate_devices/02-enumerate_devices.cpp:27:
utils/util.hpp:162:5: error: ‘xcb_connection_t’ does not name a type
xcb_connection_t *connection;
^~~~~~~~~~~~~~~~
utils/util.hpp:163:5: error: ‘xcb_screen_t’ does not name a type; did you mean ‘__socklen_t’?
xcb_screen_t *screen;
^~~~~~~~~~~~
__socklen_t
utils/util.hpp:164:5: error: ‘xcb_window_t’ does not name a type; did you mean ‘__ino_t’?
xcb_window_t window;
^~~~~~~~~~~~
__ino_t
utils/util.hpp:165:5: error: ‘xcb_intern_atom_reply_t’ does not name a type
xcb_intern_atom_reply_t *atom_wm_delete_window;
^~~~~~~~~~~~~~~~~~~~~~~

Hi Traversity,

Our Vulkan team is investigating this issue, the status will be updated once clarified how this error happened.

Thanks

Hi Traversitym

Have you tried with sudo apt-get install libx11-xcb-dev?

Hi Traversitym

The instructions to build the Vulkan Samples are:

  1. Build Vulkan loader with the instructions from https://developer.nvidia.com/embedded/vulkan
  2. Build glslangValidator and spriv-as tools for aarch64 in $HOME
  1. cd $HOME && git clone https://github.com/LunarG/VulkanSamples.git
  2. mkdir build && cd build
  3. cp …/…/glslang/build/StandAlone/glslangValidator …/glslang/bin/glslangValidator
  4. cp …/…/glslang/build/External/spirv-tools/tools/spirv-as …/spirv-tools/bin/spirv-as
  5. cmake -DCMAKE_BUILD_TYPE=Debug -DVULKAN_HEADERS_INSTALL_DIR=(pwd)/../../Vulkan-Loader/build/Vulkan-Headers/build/install -DVULKAN_LOADER_INSTALL_DIR=(pwd)/…/…/Vulkan-Loader/build/loader -DCMAKE_INSTALL_PREFIX=install …
  6. make -j8