Wake on lan issue

My Xavier NX board system information is:

  • NVIDIA Jetson Xavier NX (Developer Kit Version)
    • Jetpack 4.6 [L4T 32.6.1]
    • NV Power Mode: MODE_15W_6CORE - Type: 2
    • jetson_stats.service: active
  • Board info:
    • Type: Xavier NX (Developer Kit Version)
    • SOC Family: tegra194 - ID:25
    • Module: P3668 - Board: P3509-000
    • Code Name: jakku
    • CUDA GPU architecture (ARCH_BIN): 7.2
    • Serial Number: 1424920027702

We need support to wake up our NX device from suspend over lan using WOL magic packet. We enable WOL with ethtool. But we still saw below issues:

  1. If NX device is not in suspend state, we send WOL magic packet to our device, then we put the NX into suspend. The NX device can’t be waked up from suspend by WOL magic packet.
  2. If NX device is put into suspend, and we send WOL magic packet to NX device, the NX device can be waked up from suspend, but the network is not available, we can’t ping the NX device. We have to ifconfig eth0 down, then ifconfig eth0 up to restart network interface to make it work.

Please upgrade to jp4.6.3 and test again. We don’t debug on old release.

Also, first test case sounds not valid to me. We should only focus on the 2nd case here.

OK. We will try 4.6.3.

Is this known issue on jp4.6?

For the first case, it should be also an issue. The NX device should be able to be waked up even the device receives WOL not in susped state.

Could you clarify what command and state was first scenario using?

Wake from power off mode is not supported on Xavier. It may be supported on Orin in future, but Xavier won’t have it.

Also, is that case able to work if you use AGX Xavier but not Xavier NX?

For the first scenario, it is not to wake up from power off mode. The test step is:

  1. the NX device is on active/working state
  2. send WOL magic packet from Lan to the NX device, since the NX is in active mode, we wont see any effect.
  3. suspend the NX device
  4. send WOL magic packet to NX from lan, the NX device can’t be waked up.

Oh ok. I see your point. Please test both cases on jp4.6.3. Thanks.

@WayneWWW ,

We tried jp4.6.3. The first issue is gone, but we still see the second issue. When the NX device is waked up by WOL magic packet, the network does not work. We can’t ping the NX device. If we do ifconfig eth0 down, ifconfig eth0 up, then we have network.

It looks like we cannot reproduce this issue. Have you tried other hub/switch to test this?

yes. We tried other switch and also failed to ping the NX device.

The NX device can be waked by WOL magic packet, so the WOL packet can reach the NX device. It should not be switch issue.

When you operate those, is the desktop GUI enabled or disabled?

desktop GUI is enabled.