WARNING: erroneous pipeline: no element "nvvideo4linux2"

Hi All,

I am trying to install deepstream and run the pipeline in CPU as well as GPU

gst-launch-1.0 rtspsrc location=rtsp://root:rootroot@10.102.2.84:554/axis-media/media.amp latency=200 name=src src. ! rtph264depay ! h264parse ! avdec_h264 ! queue ! autovideosink

The above works in CPU mode.

But while I run the below pipeline,

gst-launch-1.0 rtspsrc location= rtsp://root:rootroot@10.102.2.84:554/axis-media/media.amp name=src src. ! rtph264depay ! h264parse ! nvvideo4linux2 ! nvvideoconvert ! autovideosink

I get an error "WARNING: erroneous pipeline: no element “nvvideo4linux2"”

I am using,

  • Ubuntu 18.04
  • Cuda 10.1
  • Nvidia Driver 418.116
  • Tensorrt 6.0
  • Deepstream 4.0.1/2
  • Can anyone provide a possible solution to rectify this error? Also kindly provide a proper installation instruction for installing Tensorrt and Deepstream and assigning paths in the desktop.

    Thanks…

    Hi,
    The correct name is nvv4l2decoder. If you still canot see it, please clean the cache and try again.

    $ rm ${HOME}/.cache/gstreamer-1.0/registry.x86_64.bin
    

    I got the correct pipeline for running the rtsp raw stream using Tesla T4 GPU

    gst-launch-1.0 rtspsrc location=rtsp://root:admin123@10.0.1.3:554/axis-media/media.amp?streamprofile=H264 ! rtph264depay ! h264parse ! nvv4l2decoder ! nvvideoconvert ! autovideosink
    

    This runs with 2seconds latency
    Add the latency parameter along to run realtime streaming

    gst-launch-1.0 rtspsrc location=rtsp://root:admin123@10.0.1.3:554/axis-media/media.amp?streamprofile=H264 latency=200 ! rtph264depay ! h264parse ! nvv4l2decoder ! nvvideoconvert ! autovideosink
    

    @DaneLLL Thankyou!

    @DaneLLL Thankyou!