WARNING: invalid symbol information detected for pointer typ

Hi all,

Relative newbie here, but I get an interesting warning when trying to debug my code with pgdbg.

There are many files in the program, but when I switch to the file I am interested in debugging within pgdbg, it says:

WARNING: invalid symbol information detected for pointer type

multiple times. From there, all the line numbers are greyed out, and I get errors when trying to set breakpoints

ERROR: Cannot set breakpoint at line:…

The other files in the code seem to want to debug ok, and the code itself runs perfectly well, even with all the debugging flags. The file in question contains a module, though even the routines/functions outside this module cannot have breakpoints set. I think the problem may be to do with the following construct in the module which it is having difficulty with:

TYPE ExcitGenerator
        INTEGER , ALLOCATABLE :: ExcitData(:) 
        INTEGER :: nExcitMemLen               
        LOGICAL :: ExitGenForDet=.false.
END TYPE
TYPE(ExcitGenerator) , ALLOCATABLE , TARGET :: WalkVecExcits(:),WalkVec2Excits(:)
TYPE(ExcitGenerator) , POINTER :: CurrentExcits(:), NewExcits(:)

In the program, I allocate WalkVec(2)Excits, which are pointed to by CurrentExcits/NewExcits. I then allocate/deallocate the individual ExcitData components as I need them. This works fine when running the code, and may not be the cause of pgdbg’s problem.

I compile the file with pgf90 -c -g -r8 pc=64 -Msignextend -Minform=warn -Msecond_underscore -Mfree FciMC.f90

Hope you can help.
Thanks

I thought i’d mention that I’m using PGDBG 7.2-2 x86-64 if thats an issue.

Thanks again

Hi George,

I sent this on to our tools engineers who believe it might be an issue with the use of “-Msecond_underscore” and the debugger not resolving how the symbol is decorated. Can you please send an example to PGI customer support at trs@pgroup.com so we can have out engineers take look?

Also, do need “-Msecond_underscore” for GNU compatibility or are you able to compile your code without the flag?

Thanks,
Mat

Hi George,

Our tools team has tried multiple configurations but has been unable to reproduce the problem. Can you please send and example to PGI customer support at trs@pgroup.com?

Thanks,
Mat