"Warning "Test Key is Used" AGX Xavier Development Kit New Flash

Hey there,

I have the Jetson AGX Xavier Development Kit and I flashed the latest 5.1.1 JetPack using SDK Manager. For the setup for my development kit I followed the manual setup instructions where the Xavier is in recovery mode. The SDK manager flash finished installing but when I attach a monitor to my Xavier, I see the warning Test Key is Used and the fan goes loud before it seems to enter a constant state of rebooting.

I have gone through a lot of the forums and I have even left it on overnight to see if it will boot and it does not. Currently there is no M2 drive plugged in or ethernet. I have reflashed using SDK manager at least two times now for 5.1.1. Do you have any recommendations?

The rebooting is obviously a problem, but the “test key” is not a problem. During flash the equivalent of BIOS content and boot content (at least that content in the non-rootfs partitions of eMMC models like the AGX) is signed. There is an option to burn security fuses, and from then on those partitions cannot be used unless the signature matches the burned fuses. Without burning the fuses those partitions are still signed, but the signature is a NULL signature. That’s the “test key”. It’s just warning you that signed content has a publicly known key, and it is up to you to burn fuses if you want to guarantee that content for security purposes.

Fans on Jetsons do not normally run. Most of the time you will hear the fan spin up for about half a second as it turns on, and then it turns off. That’s because it is an energy efficient device, and the fan only goes on when the temperature goes up enough to need it. So that part is not a problem.

Two things will help:

  • A serial console boot log. This log works even in boot stages, and logs to the remote host PC since it is that remote computer that has the serial console terminal program. You simply tell it to log the session before starting boot, and then boot. A log will generate, and when reboot has occurred once, you can stop logging and attach the log to this forum.
  • You need to describe your host PC platform. Be details about:
    • Is it Ubuntu 20.04? Ubuntu 18.04?
    • Is it a VM? Hopefully not, because these have problems.
    • The JetPack/SDK Manager software has an “export logs” button. Can you export the logs of the flash, and attach them to the forum? I’m not sure if you can go back later and export the logs, maybe you can; perhaps you have to export before exiting sdkmanager, not sure.
    • Have you ever had the m.2 attached during flash?
    • Has the Jetson worked previously?


Thanks for the response, is there a program to capture the boot log? (is it SDK manager)

It was Jetpack 5.1.1
Ubuntu 20.04 (i have no 18.04)
Not a VM
Which logs do you need specifically? (Theres over 20 in the zip folder)
I had m2 attached before but I removed it before last flash
Yes jetson has worked previously

SDK Manager has an export logs button. However, that’s for debugging flash. To debug the Jetson itself you need the serial console log. In the case of SDKM, you’d attach a zip of the entire set of files. I have to emphasize though that the Jetson itself will produce a log via serial console, and this is needed (the Jetson is already flashed, now you are looking for why boot fails). Serial console is unique in that it survives most software failures, and it also runs during boot stages. It is hard to emphasize how important that is.

Incidentally, you should flash it normally without external media. Debug that. Then you would probably use initrd flash for external media.

Hey i solved this issue! but I will open another topic for a different one with kernel customization

@henry.jeng , glad to see you’ve moved forward!

However, as you’ve been publicly asking for help and someone took time to help you, it may be a bit frustrating if you don’t share how you’ve solved it for this user and next users facing the same and reaching here for that.
Don’t be shy!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.