Warning: Test key is used (Orin nano 16gb)

Hello. I’m using Jetson Orin nano 16Gb ,but suddenly is not working(going to power save mode). When booting it’s shows Warning;test key is used . Can you help to solve this problem?

This is actually the older Nano forum, not the Orin forum. You’ll want to post here:

Incidentally, the test key warning is unrelated and shows up on all systems unless you’ve burned security keys and flashed with your own private key. What you really need is a serial console boot log. I’ll suggest post on the Orin forums and add the serial console log. Also, state which release you are using (on the SD card see “head -n 1 /etc/nv_tegra_release” (you can check that SD on a host PC, although you’d have to prepend the mount point of the SD card). Include whether you’ve flashed the Jetson itself (the SD card is the operating system, but QSPI memory on the module itself has most of the boot content, plus equivalent of BIOS).

I just used SDK manager to install packages and on the procces Flashing ,on the last moments it’s failed and stopped detection board. By the way when it restart device actuall it has before different name when it’s restaring it has a new name of device (like 64gb). So now it’s just not detection by host PC and if running device just shows test key is used and goes to power save mode.


I’m not quite sure about what you are talking about here. (I mean both grammatically and semantically…) Can you elaborate it more?

Also, please attach the UART log and the flashing log so we can debug for you. Your last sentence does not give any useful information indeed.

I’ve tried install packages through the SDK manager. When I run set up procces and in the proccess of Flashing Jetson I got an error(failed ). After that my host PC stopped detecting board. When i’ve tried check device by plugging it power and connection to monitor it goes to power safe mode. Shows Warning: test key is used and goes power saving mode. Can’t attach failure screen of flashing because i clossed it and now it’s not detection board.


couple of things here:

  1. First of all, we don’t have Orin Nano 16GB in our line up. What device do you use exactly?
  2. I think there is no such power saving mode, and it’s just your device hangs up and gives no response after entering UEFI.
  3. What do you mean with not detecting board? Can you see the following message on your host with lsusb after putting the device into force recovery mode?

Bus <bbb> Device <ddd>: ID 0955: <nnnn> Nvidia Corp.

  1. Please just re-flash the device and put any kinds of log you can get here. (UART log and flashing log)

1)Jetson Orin NX 16GB.
3)Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 022: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 023: ID 0955:7323 NVidia Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
4) i didn’t get this part. How i reflash if host pc can’t detect board? and no responce after entering UEFI?


you didn’t answer my question. What exactly do you mean with not detecting board? You should be able to start the flashing process as your host PC can detect that you device is now in force recovery mode, which is shown you #3 in your reply.

  1. When i open SDK Manager and it’s not detection board. Previously it automatically detected. Now i have to choose manually from the list,but even on the flashing moment it says no board connected.

Trying now SDK Manager but got an error


you should choose Manual Setup in SDK Manager.

Got error with manual set up


what storage device do you want to flash into? Did you choose the right option in step 6?

In option i have NVme, USB,custom. I’ve tried with first two and failed.

I mean you have to choose the right option according to your hardware setup. If your device is quipped with an NVMe SSD, then choose NVMe; if it’s a USB drive, then choose USB.

Can you first validate on your host PC that your storage device is functioning properly?

Error: Could not stat device /dev/xxx

means SDK Manger cannot detect the storage device you just choose in step 6.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.