WARNING: [TRT]: Unable to determine GPU memory usage Segmentation fault (core dumped)

I’m working with jetson agx orin with Tensorrt 8.5.2 and DS 6.2 & jETPACK 5.1.
When checking tensorrt version it showed 8.5.2 for cuda 11.4 however when i tried to import tensorrt it showed an error so i have installed TRT 8.5.2, CUDA 11.8 as 11.4 is not available in this link Log in | NVIDIA Developer
The below error has been generated when trying to run my DS pipeline
Warning: ‘input-dims’ parameter has been deprecated. Use ‘infer-dims’ instead.
WARNING: [TRT]: Unable to determine GPU memory usage
WARNING: [TRT]: Unable to determine GPU memory usage
WARNING: [TRT]: CUDA initialization failure with error: 222. Please check your CUDA installation: NVIDIA CUDA Installation Guide for Linux
Segmentation fault (core dumped)

is there a way to get to the older vserion of TRT that is compatible with my DS?

Please refer to the installation steps from the below link if in case you are missing on anything

Also, we suggest you to use TRT NGC containers to avoid any system dependency related issues.


I have followed exact steps and i’m not facing issues with installing the issue is i need the tensorrt 8.5.2 for cuda 11.4 which i wasn’t able to find


We are moving this post to the Jetson AGX Orin forum to get better help.

Thank you.


Deepstream 6.2 should work well with the default packages contained in the JetPack 5.1 GA.
Which error do you meet when importing TensorRT?


That tensorrt is not installed however when i run the command to check version it used to show 8.5.2.

why you don’t read the title


How do you install the components packages?
Could you try it with SDKmanager?


just upgrade jetpack

yes initially i have installed it using Manager SDK. but now i have uninstalled TRT for CUDA 11.4 and i’m looking for other options other than flashing the GPU


Please see TensorRT Installation - #10 by AastaLLL

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.