Warning when trying to view the RTSP generated by DeepStream

Hi,
So when I try to access the RTSP Stream generated by DeepStream, I am getting this Warning message.
I tried to find ‘pt’ keyword in the files, but have not been able to.
Can you tell me how to fix it?

GLib-GObject-WARNING **: 13:46:13.097: g_object_get_is_valid_property: object class 'GstUDPSrc' has no property named 'pt'

Thanks.

Hi,
For running a gstreamer pipeline, you should use rtspsrc.

You may also try VLC:
https://devtalk.nvidia.com/default/topic/1061580/deepstream-sdk/how-do-i-view-the-output-through-the-rtsp-/post/5375714/#5375714

I am just using the RTSP sink option. I am able to view the stream but I keep getting this warning anytime I open the stream.

Hi,
So you enable type=4:Encode+RTSP streaming in running deepstream-app and observe the warning?
https://docs.nvidia.com/metropolis/deepstream/dev-guide/index.html#page/DeepStream_Development_Guide%2Fdeepstream_app_config.3.2.html%23wwpID0ENHA

Hi,
The print is harmless and please ignore it. We will check to fix it in future release.

Hello can you tell me how did you fix your problem, i’m having the exact same problem using the python binding code.
Trying to do a RTSP streaming using a nvarguscamerasrc,

Everything works, but when i open VLC and try to connect to the URL I get the same error:

sys:1: Warning: g_object_get_is_valid_property: object class ‘GstUDPSrc’ has no property named ‘pt’

Where exactly you set the type=4?

I’m using python and deepstream5

Hey,
This is just a warning message and it doesn’t seem to do any kind of harm as I have been running my code for quite sometime without any problems.

The type=4 was for using deepstream-app in Deepstream 4.0.1. It is an RTSP Sink.

Hey thank you for your answer i’m working with python trying to make this example working:

i got that error i’m not sure what the problem is, @DaneLLL

My RTSP stream doesn’t appear on the vlc player, when i connect to the stream, the error appear in the console, no image yet.

Hi,
The prints are warning. If you use DeepStream SDK 5.0 GA, please start a new topic.