Waypoints in Kaya Navigate

Hello,

When running the navigate app, trying to navigate to waypoints does not seem to work. When using random poses it works fine.

  • Change goals.waypoint_as_goal config to desired waypoint.
  • Change goals.goal_behavior from ‘random’ to ‘waypoint’
  • ‘Map View’ displays waypoint as goal pose
  • Hold down R1 for autonomous mode
  • No plan is displayed, Kaya is stationary.

Again, everything about works fine with ‘random’ as goal behavior.

Any ideas?

The ‘pose’ goal_behavior works as expected was well. I might just convert a waypoint to a pose and use that, but I am really confused on why ‘waypoint’ goal_behavior does not work.

More info:

When I switch to ‘waypoint’ behavior, the channel ‘navigate/navigation.planner.global_plan/isaac.planner.GlobalPlanner/path’ displays this:

“Channel is disabled because the coordinate frames are not connected: [map_T_####, ] is not defined”

I understand ‘####’ is the default frame? Why is it using this? Is it a mistake on my part somewhere?

Solved… Apparently my waypoints in the map were too close to a “wall” so there was no valid path in the eyes of the planner. 🤦‍♂️🤦‍♂️

1 Like