We cannot access to Omniverse XR by NVIDIA Omniverse XR Remote

Hi,

I’m testing Omniverse XR and currently we cannot access by Omniverse XR Remote App.
We can access and show contents in case of Omniverse Create 2021.3.8.

We are unclear this is because of the version of Omniverse XR Remote App or
other reasons.

[Environment]
All applications are instlled in the same environment.

  1. Omniverse Create 2021.3.8
  2. Omniverse XR 2021.1.0
  3. I do not install any Cloud XR SDK.
    So application should use cloudxr clients that each application has internally.

[Investigation]

  1. If we open Omniverse XR and select TabletAR tab to move other place,
    we got an error regarding omni.ui.
    Also this error is output each time we select “Start Tablet AR” and “Stop Table AR”.
  2. We tried both “CloudXR” and “SimulatedXR” but the same results. But the console messages are different. We do not change any parameters.
    In addition we do not know what does the message in 3D scene “XR display is turned off” mean.

I tried by two PCs. ( both are Windows 10 )
One has 2080Ti ( Desktop ) and the other has 3070 ( Note PC ) and both are the same result.

  1. We compared cloudxr between 2021.3.8 and Omniverse XR.
    It looks several files are different.
  • 2021.3.8
    …\AppData\Local\ov\pkg\create-2021.3.8\kit\xrclients\windows
  • OmniverseXR
    …\AppData\Local\ov\pkg\xr-2022.1.0\exts\omni.kit.xr.system.cloudxr21\xrclients\windows

So as my challenge, replace files in “\xr-2022.1.0\exts\omni.kit.xr.system.cloudxr21\xrclients\windows” by other versions.
This is because if installed version of CloudXR SDK and client version are different,
we cannot access to CloudXR server.

I have tried below but unfortunately all are the same results. We cannot access.

  • Create 2021.3.8
  • 2021-04-28-CloudXR-SDK\Client\Lib\Windows
  • 2021-08-04-CloudXR-SDK\Client\Lib\Windows

Sorry there is possibility tha my investigation is besides the point but at least
we cannot access by Omniverse XR Remote.
Other person tried by SteamVR with Android phone ( use Cloud XR client ) and
in this case we can access to Omniverse XR correctly.

===

Masahiro Suzuoki

Hi,
I forgot to describe 1 topic.

In Omniverse XR, after we enable “Start Table AR”, then select
“Stop Table AR” to disable Tablet AR, application hung up.
We confirmed by several environment and this issue occurs in all environment.

===

Masahiro Suzuoki / CTC

Same problem with Windows 10 and RTX 3090 game ready driver 512.15.
I also had it working with the older version of Create.

Brad Carvey

Hi,
Thank you for the answer.

Currently I’m using Gaming Driver 512.77.
Now we can use Tablet AR feature by Omniverse XR but we have the issue below.
Other environment has the same issue so we think this is not regarding the environment.

  1. Launch Omniverse XR
  2. In Tablet AR feature, enable Tablet AR by pressing “Start Tablet AR”.
    ==> We can access by Omniverse XR Remote application to Omniverse XR.
  3. Disable Tablet AR by pressing “Stop Tablet AR”.
    ==> Omniverse XR hung up.
    This issue occurs when we access by XR Remote application.
    Even if we just press “Start Tablet AR” and “Stop Tablet AR” this issue does not occur.

We think reported issue as “213448” is similar issue.

===

Masahiro Suzuoki / CTC