Webcam audio problem - Jetson TK1 - Grinch 21.3.4

I am using Logitech Webcams (C920 and C270) on 3.10.40-grinch-21.3.4 kernel
There is no webcam audio source when webcam is plugged in.

Tested on two boards with Grinch.
On the another 2 boards:

  • these cameras work with originally installed L4T (R19.3 ?) both - video + audio
  • work with L4T 21.3 with original kernel (both - video + audio)
  • After instalation of the Grinch kernel 21.3.4 the pactl list | grep alsa_input results in one source while the video is working normally

Info when only C270 is plugged: (same problem with c920)

ubuntu@tegra-ubuntu:~$ lsusb
Bus 002 Device 002: ID 05e3:0612 Genesys Logic, Inc. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 002: ID 05e3:0612 Genesys Logic, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ubuntu@tegra-ubuntu:~$ pactl list | grep alsa_input
	Name: alsa_input.platform-tegra-snd-rt5639.0.analog-stereo

ubuntu@tegra-ubuntu:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: tegrart5639 [tegra-rt5639], device 0: rt5639 PCM rt5639-aif1-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrart5639 [tegra-rt5639], device 2: BT SCO PCM dit-hifi-2 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrart5639 [tegra-rt5639], device 3: VOICE CALL PCM rt5639-aif1-3 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrart5639 [tegra-rt5639], device 4: BT VOICE CALL PCM dit-hifi-4 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrart5639 [tegra-rt5639], device 5: offload-pcm (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrart5639 [tegra-rt5639], device 7: offload-pcm-capture snd-soc-dummy-dai-7 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ubuntu@tegra-ubuntu:~$ cat /proc/asound/cards 
 0 [Tegra          ]: HDA-Intel - HDA NVIDIA Tegra
                      HDA NVIDIA Tegra at 0x70038000 irq 113
 1 [tegrart5639    ]: tegra-rt5639 - tegra-rt5639
                      tegra-rt5639

How to make webcam audio back to work on Grinch 21.3.4?