Websight Window Dimensions

Hi all,

I am doing object detection on videos via DeepStream module. Even though I specifically set window dimensions in my JSON file for the Websight server (752x420), they always return to the original dimensions of the video and the “Automatic” box gets selected under the Window Dimension settings in Websight.
This prevents me from seeing the object labels, if the detection bounding box aligns with the window edge. I can only change it manually when the app is running on the window (s. picture with black area below the window). Is there a way to lock the dimensions to specific values beforehand?

Here is my websight-config attribute in JSON:

    "websight": {
      "WebsightServer": {
        "webroot": "/home/ga35baq/isaac/packages/sight/webroot",
        "port": 3000,
        "ui_config": {
          "windows": {
            "Yolo Detection": {
              "renderer": "2d",
              "dims": {
                "width": 752,
                "height": 420,
                "automatic": false
              },
              "channels": [
                {"name": "$(fullname yolo_tracker_app/viewer/ColorCameraViewer/Color)"}, 
                {"name": "$(fullname yolo_tracker_app/detection_viewer/isaac.viewers.DetectionsViewer/detections)"}
              ]
            }
          }
        }
      }
    }

Here’s the output of the “Yolo Detection” window when I run the app.


Here is the setting that come automatically:

Here is the desired output:

On initial inspection, your config seems fine. Have you tried with a new Incognito window with Isaac Websight and see if you get similar behavior? My theory is that the site cached the absence of custom dimensions, so it is defaulting to automatic and resizing on its own, ignoring your config parameters.

Hi,

I am sorry for the inconvenience, this feature is poorly (or not at all) documented.
It is intended that when the first channel is an image, the renderer automatically resize to it, this is most of the time the expected behavior. However there is indeed a way to get the window at the dimension you want. See the config below that I updated:

You need to add custom_dimensions to the config.

In addition, in general the browser remembers the previous parameters you were using, if you had created another renderer from the UI directly, it would have remembered, however because you used the config directly (which is totally normal), it kept overwriting the last configuration where you set the custom dimensions to true. That was unfortunate, and we should probably document better how to achieve this result using the config.

Anyway, I hope this solves your problem, and I am sorry for the inconvenience.

Regards,

Ben

Thank you, custom_dimensions works like a charm.