Weird behavior of UR5 with Robotiq 2f-85 in FollowTarget example


I am trying to setup the environment with UR5 arm and Robotiq 2f-85 gripper (both from the Isaac Assets).

When I load the USD with the FollowTarget example, I am observing a weird behavior, where the base of the arm is being shifted to another location (I assume its shifting to the location of joint between arm and the gripper).

Interesting thing here is it works properly after the base is shifted.

I am not sure if I am did something wrong in creating the USD. I am attaching the USD for the reference.

I would really appreciate any help in solving this issue.

Thanks in advance.

Best regards,
Vamsi Kalagaturu

ur5_85_assets.usd (9.4 KB)

Attaching the video of the behavior for reference.

follow_target-2023-05-10_10.10.07 (7.5 MB)

Hi @vamsi.kalagaturu - Someone from our team will review and get back to you.

@rthaker Can I get any update regarding the issue mentioned?

@vamsi.kalagaturu I am having trouble opening the asset that you shared. The robot and table are not showing up on the stage. The asset path in the asset that isn’t showing up is omniverse://localhost/NVIDIA/Assets/Isaac/2022.2.1/Isaac/Robots/UniversalRobots/ur5/ur5.usd, which is not one I am used to seeing. Can you share a zip with the code that loads your robot and runs your extension?

Hello, have you solved your problem? I am envious that your base can move normally although it has moved, and I am using ur5e to follow_target task, but once it runs, the robot arm will fly around. The video is as follows. Have you ever encountered such a problem? I looked at the description and rmpflow configuration file of UR10 in the examples, and neither was solved, too painful.
If you have any ideas, could you help me? Thank you so much! (1004.3 KB)