Weird DE Lag in KDE with X 550.1.54.14-1, Refresh rate drops with other drivers and in wayland

Recently, I’ve been having issues with laggy animations in KDE plasma when using X. I have two monitors with slightly different refresh rates (60hz, 59.94hz). The most noticeable lag occurs when switching virtual desktops. It seems as though the animation just plays less frames, as when I slow it down, it seems that the number of frames displayed stays the same but the speed decreases. When I start up, the issue isn’t present, then, it starts to occur when switching between desktops that have windows and desktops that have no windows (except for system settings and steam for some reason, these have no effect). Finally, it starts happening when switching between all desktops. Starting apps also causes lag, and moving and resizing windows also seems to happen at a reduced framerate. I have tried the solution described in this reddit post to no avail. Upon reading logs (xorg log, journalctl), I didn’t notice anything of interest, but I would be more than willing to provide them.

Previously, with the 545 drivers, I believe I was experiencing this issue when running games, where the reported FPS would stay steady, but the perceived fps was clearly dropping to sub 60 levels. This no longer occurs with the 550.1.54.14-1 drivers; however, it reoccurs with the 550.1.54.14-4 drivers. Because of this, I am using the downgraded 550.1.54.14-1 driver, and switching to another version that has this stuttering issue is not an option for me.

On Wayland, I also have similar stuttering issues when running XWayland games in fullscreen with the 14-4 drivers and xorg-xwayland-explicit-sync. The stuttering seems to be fixed by running games in borderless windows, but then I believe I experience screen tearing or some other kind of choppiness, but it’s very subtle. Also, when I cap the FPS at 60, and it ever drops below that 60, I get what I believe is out-of-office frames (juttering of the camera). Aside from that, I tried a variety of different settings combinations, but would always either get tearing, strange stuttering, or out-of-order frames. I also experience bugs with some other XWayland desktop apps that makes Wayland not a viable option at the moment for me.

Note: the game I’ve been testing with is risk of rain 2 with proton, but I’ve at least experienced the refresh rate drops with Overwatch 2, so it’s not localized to Risk of Rain 2

Here is my neofetch:

                                           OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: G5 5090 
             `-/ossssssssssssso/.          Kernel: 6.7.9-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 1 hour, 1 min 
         `-:/+sssssssssssssssssso+/.       Packages: 1341 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.2.26 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080, 1366x768 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 6.0.2 
  `:////ssssssssssssssssssssssssssso+++.   WM: KWin 
`-////+ssssssssssssssssssssssssssso++++-   Theme: [Plasma] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: [Plasma], breeze-dark [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Terminal: konsole 
  `:::::::::::::::::::::::::------``       CPU: Intel i5-9400 (6) @ 4.100GHz 
                                           GPU: NVIDIA GeForce RTX 4060 
                                           Memory: 7844MiB / 15851MiB 

My nvidia-bug-report.sh output:
nvidia-bug-report.log.gz (1.7 MB)

Regarding lag in Xorg/KDE 6, please see this bug report I made: Read the last comment:
https://bugs.kde.org/show_bug.cgi?id=482717

TLDR; turn off adaptive opacity for the bottom bar.

That doesn’t seem to affect the bug for me unfortunately

Actually, I just realized I also had a dock that still had adaptive opacity that was on the right side of my screen. Changing to opaque on the dock as well fixed the bug.

Yeah, I also think having the dock “floating” makes it stutter too. So that mode needs to be off as well.
It seems like a bug that affects nvidia and the proprietary driver.vSome Intel drivers are also affected.

I seem to still be having the issue even after disabling floating, although it’s more inconsistent.