Weird workaround to install Jetson TX1 card


I want to point out a weird thing that I saw back when I installed my TK1 that is repeating now with the TX1 : if I simply add exec rights to the JetPack “” file and launch the install process, I will eventually end up stuck at the login screen where it asks for the IP and the credentials of the remote card. SSHing the card works great.

What I have found is that I must launch the “” as root, so I sudo it.

sudo ./

But then I get stuck in the middle where the login screen should appear (in fact it goes right to the end screen of the install). So I had to give 775 rights to all content of your jetpack install directory

sudo chmod -R 775 /yourjetpackinstalldir/

Only that allows me to get past the connect screen.

To avoid getting some libraries not installed correctly (, double check to be on the same switch, not only the same network.

my experience was much different. i ran the installer from the directory that i wanted the package to install on the host. as directed i gave the package x right. then i ran the installer without sudo nor as root. i was asked twice for the password of the host. the installer never asked about the target. the installer was able to determine the target IP correctly and as far as i can determine installed everything correctly. i felt that the installer was much improved over the prior one but that might just be from having the experience of 3 installs to a tk1 and 2 installs to a tx1. although nothing was advertised as changed for the tk1 i did a new install for that also since i was thinking some of the changes might also update tk1. it all worked so well i’m puzzled why you had to alter a bunch.

Wish you had posted this 2 months ago! Thanks for sharing.

@dkryder : I had problems with my first install of the TX1, so I double checked everything and restarted from scratch. This time around I didn’t need to do all this sudo and chmod 775. Everything worked as advertised in the documentation. I don’t know why.

I remember that one time I tried the installation from my laptop, so the Wifi could have been the troublemaker. Avoid Wifi. But the other times I was installing with a local NETGEAR switch. Also never trust your company network, it can have weird settings. That’s why I asked to have a netgear switch on my desk.