What are the minimum steps to reflash a Linux kernel and rootfs?

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.4.0.7363
other

Host Machine Version
native Ubuntu 18.04
other

Hello,

The SDK Manager appears to erase and re-unpack everything so cannot be used to flash a customized staging area.
The entire flash process is onerous.
What are the minimum steps to follow to flash a Linux kernel image, dts file/s, and new root file-system?

Hi @sbarber ,

Please check if below help. Thanks.

Thank you.

Some of the instruction say to run a make -f Makefile.bind … first.
Is this necessary? What does this step accomplish?

Please see Install Ubuntu ‘Binding the Solution’


After following the steps given to flash the x1 fails to boot.
I updated the dirname in the closest matching cfg file, quickboot_emmc_linux.cfg, to targetfs_a as there is no targetfs.
I tried it again with the dirname set back to targetfs; same results.

./bootburn.sh -x /dev/ttyUSB3 -b e3550b03-t194a -B qspi

[ 4.572217] tegradc 15230000.nvdisplay: probed
[ 4.573961] tegradc 15230000.nvdisplay: fb registered
[ 4.575907] gpio tegra-gpio wake66 for gpio=99(M:3)
[ 4.576111] carmel_ras carmel_ra: Deferring probe, arm64_ras hasnt been probed yet
[ 4.582419] Freeing unused kernel memory: 7168K
[ 4.721756] INITRAMFS STARTS
Getting target_board from device-tree …
[ 4.933079] EXT4-fs (vblkdev0p1): recovery complete
[ 4.934708] EXT4-fs (vblkdev0p1): mounted filesystem with ordered data mode. Opts: (null)
mount: ‘/proc’->’/new_root//proc’: No such file or directory
mount: ‘/sys’->’/new_root//sys’: No such file or directory
mount: ‘/dev’->’/new_root//dev’: No such file or directory
[ 5.000363] Trying chroot to /new_root
[ 5.001975] INITRAMFS END
chroot: exec /sbin/init: No such file or directory
[ 5.006393] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00
[ 5.006393]
[ 5.006406] SMP: stopping secondary CPUs
[ 5.006478] Kernel Offset: disabled
[ 5.006485] CPU features: 0x1002230
[ 5.006487] Memory Limit: none

Could you elaborate your steps and provide the modified files for my reproducing? Thanks.

Build kernel and copy/install to staging area per instructions here.

Then
cd ./drive-t186ref-foundation
make -f Makefile.bind PCT=linux BOARD=e3550b03-t194a
./tools/host/flashtools/bootburn_t19x/bootburn.sh -x /dev/ttyUSB3 -b e3550b03-t194a -B qspi

I set the dirname to targetfs_a but it is still looking for targetfs.
quickboot_qspi_linux.cfg:234:dirname=/srv/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/targetfs_a

I tried making a symlink for targetfs to targetfs but it appears to flash the symlink and doesn’t follow it as it only flashes 17408 bytes for the fs partition and there is an resizing error.

Flashing for Partition A_1_gos1-gp1 (Size: 17408 bytes, Time: 0.169 seconds)
1% done(Size: 524288 bytes, Time: 6.126 seconds)
24% done(Size: 202928 bytes, Time: 1.929 seconds)
49% done(Size: 202928 bytes, Time: 1.840 seconds)
100% donefor Partition pt
Resizing filesytem on /dev/block/3460000.sdhci...
3460000.sdhci not found in partitions! Trying to map with controller instances...
Using mmcblk0 as the local partition!

I was able to flash by moving targetfs_a to targetfs

So this question has shifted to, what is the correct location to set the targetfs dirname?
Setting it in DRIVEOS/drive-t186ref-foundation/tools/host/flashtools/bootburn_t19x/quickboot_qspi_linux.cfg does not work.