What is sure shot way to know from terminal if Jetson is in Force recovery mode?

I have tried running libusb, where i see the NVIDIA device but when i run sudo ./flash.sh -r cti/tx2i/elroy-revF+ mmcblk0p1 it complains the device is not in recovery mode with following error.


After fiddling with cables and power cycling the Jetson i was able to eventually flash. I am wondering if there is a way to check with certainty that the jetson is indeed in recovery mode? Or is flash script is the best the way to check if device is in recovery mode?

Hi @discobotjetson

You can check the recovery mode by using “lsusb” command. The device number of Nvidia Corp should be different when you are in recovery mode.

For example, the device number is seen as “7020” normally.

Screenshot from 2021-03-15 11-25-50

When you are in recovery mode, the device number is seen as “7c18”.

Screenshot from 2021-03-15 11-26-10

Thanks @ozguryildiz. Is it always 7c18 for recovery mode?

Hi @discobotjetson

We have used TX2 module so it device number can be seen as “7c18”. The list of module device numbers are available in the link below. If you are using Jetson TX2i, you should see it as “7018”.


1 Like