What Is the Max Rootfs Size?

On the TX1 and TK1 the maximum rootfs size is specified as “-S 14580MiB”. What is the exact maximum possible on the 32GB TX2?

Hi linuxdev,

In ${JETPACK-3.0-ROOT}/64_TX2/Linux_for_Tegra_tx2/p2771-0000.conf.common, below setting is the maximum size for TX2.


I have to wonder if this is the actual value based on ROOTFSSIZE in the TX1 conf being “14GiB”, yet, “14580MiB” is the true maximum. I’m sure 28GiB is the maximum size if rounding to GiB, but since the TX1 ignores this (14GiB is smaller than 14580MiB), I suspect there is a different true absolute limit. Is ROOTFSSIZE strictly enforced in R27.x, or is it a default which can be surpassed if the flash allows writing that much eMMC?

Hi linuxdev,

How did you get “14580MiB”? The partition configuartion file (flash.xml) used in installing Jetson TX1 via JetPack has size as 15032385536 Bytes (which is 14 GiB).

I used 14580MiB earlier, I think starting with the TK1. When TX1 came out I tested that and it worked well (I’ve never had an error from that at any stage of flash or actual use…cloning verifies a correct image). I’ve always thought this would fail if there were not actually enough eMMC to do this and attributed this to be from 14580MiB being rounded when expressed as GiB. Try 14580MiB on the TX1…it’ll work (FYI I use flash.sh on command line, I don’t know if JetPack enforces things differently, but it is about hardware limits rather than flash software limits) :)

hello linuxdev,

please flash Jetson TX2 with below maximum possible rootfs size, thanks
$ sudo ./flash -S 29318MiB jetson-tx2 mmcblk0p1

I have use

sudo ./flash -S 16400MiB jetson-tx2 mmcblk0p1

cmd and set the mmcblk0p1 to 16GB, and get the mmcblk0p29 12GB, but the mmcblk0p29 can’t use directly.
What shoud I do to mount mmcblk0p29 successfully?


What do you mean you can’t use it directly? What do you see from “sudo gdisk -l /dev/mmcblk0”? How did you add the extra partition, and how did you format it?

Sorry , I have solved that problem! Just mkfs.ext4 to format and then the partition can mount