What is the problem with my TX2?

There are some issues with my TX2:

  1. recovery mode always on as soon as I push the power button.
  2. when I connected the pure HDMI, there is no output (wire and monitor are OK)
  3. I re-flash several times, but nothing change. ( using sdk manager or command line)
  4. I have tried jetpack 3.3 /4.2.3/4.5.1

Anyone can help me?

flash.txt (36.6 KB)

From the log I see this:

[  14.6328 ] Writing partition master_boot_record with mbr_1_3.bin
[  14.6359 ] [................................................] 100%
[  14.6397 ] Writing partition APP with system.img
[  14.6411 ] [................................................] 100%

…which looks good, but you did specify in the flash.sh command line “-S 28GiB”. Just to validate the image, “28GiB” is equal to “28x1024x1024x1024", which is exactly "30064771072" bytes. If you use "ls -l" on "Linux_for_Tegra/bootloader/system.img.raw`”, then does this exactly match that size? I just wanted to make sure the image flashed seemed “sane”.

Basically the flash looks correct.

If your unit is actually going straight to recovery mode, then that is indeed a hardware failure. It could be a failure of the carrier board or of the module itself, but since the button for recovery mode is on the carrier board I tend to think odds are in favor of the carrier board itself. Most people don’t have extra boards, but if you do, then you might check swapping with another carrier board to see if it follows the module or if it follows the carrier board.

One last test: If all you do is turn the unit on and don’t otherwise press any buttons, is the flash software willing to flash? If the flash software detects and is willing to flash without any manual intervention to put it in recovery mode, then that pretty much guarantees hardware failure (although it doesn’t differentiate between carrier board failure and module failure).


  1. in addition to “-S 28GiB” command, I also used “./flash.sh jetson-tx2 mmcblk0p1”, but is the same result.
  2. There is another thing I must tell: several months ago, I flashed FreeRTOS to Cortex-R5 core according to Sensor Processing Engine (SPE) Developer Guide(flash the spe.bin file). I succeeded, and into tx2’s desktop using HDMI connected monitor. After that, I left it in the box without other operations, but now I found it goes wrong.
  3. I always tried that re-flash the original spe.bin file to spe core, but not work.
  4. I only have one device, and I really want it not to be a hardware problem.

Have you checked to see if flash is allowed when you do not press the recovery button at all, and merely power up the Jetson with the micro-B USB cable connected? If this fails because the flash software can’t find the Jetson, then the Jetson is probably ok. If avoiding use of the recovery button results in flash software being able to start a flash, then this is a hardware error.

I doubt the FreeRTOS would have anything to do with it if you flashed again and only original files were in place during the flash (you might delete the flash software directory and recreate it if not sure). Flash itself would not care and will happily replace any software with the original (but as mentioned, perhaps something is still in place which you don’t know about and in need of removal for flash to put original non-FreeRTOS content in place).


  1. Yes, It it. The Ubuntu18.04 (not VM) can directly detect and do flash the device using micro-B USB cable, with merely power up.

  2. Actually, OS (just os img) can flash into this device, but those components can’t since I can’t into it’s desktop.

  3. I have searched many similar problems on this site, and tried some solutions they have mentioned, but not work.

  4. If it does a hardware failure, what support I can find to repair this error ? Is there some where I can post this device to repair ?

Thanks for answer !!!

Is it a nv devkit? Do you have other devkit carrier board on your side? If not, maybe you need to file a RMA process to replace your board.

Please check the RMA process to replace your board.

What @WayneWWW said…time for RMA, but if you have an alternate carrier board, then you could at least test if it is the carrier or module which fails via swap of carrier board. No Jetson should start in recovery mode.