What is the tegra_channel_error_status error info at Jetson TX1 R28.2?

1.What is the tegra_channel_error_status error info at Jetson TX1 R28.2?

tegra_channel_error_status:error 20022
tegra_channel_error_status:error 24022

2.The csi status is OK?or have some errors?

742.169050] vi 54080000.vi: TEGRA_CSI_PIXEL_PARSER_STATUS 0x00004000
[  742.175401] vi 54080000.vi: TEGRA_CSI_CIL_STATUS 0x00000003
[  742.180969] vi 54080000.vi: TEGRA_CSI_CILX_STATUS 0x00030030

hello sensor_test,

you could refer to below source code to understand the error reporting.

sources/kernel/kernel-4.4/drivers/media/platform/tegra/camera/csi/csi2_fops.c

int tegra_csi_error()
{
...
         val = pp_read(port, TEGRA_CSI_PIXEL_PARSER_STATUS);
         err |= val & 0x4000;
         pp_write(port, TEGRA_CSI_PIXEL_PARSER_STATUS, val);

         val = cil_read(port, TEGRA_CSI_CIL_STATUS);
         err |= val & 0x02;
         cil_write(port, TEGRA_CSI_CIL_STATUS, val);

         val = cil_read(port, TEGRA_CSI_CILX_STATUS);
         err |= val & 0x00020020;
         cil_write(port, TEGRA_CSI_CILX_STATUS, val);

in generally,
you should co-work with your hardware engineer and checking this from the sensor side, to measure the mipi signaling is output correctly.
thanks

I use devmem2 read 0x54080940 is below:

dia@tegra-ubuntu:~/yavta$ sudo devmem2 0x54080940
/dev/mem opened.
Memory mapped at address 0x7f8b16a000.
Value at address 0x54080940 (0x7f8b16a940): 0x30030
nvidia@tegra-ubuntu:~/yavta$ sudo devmem2 0x54080940
/dev/mem opened.
Memory mapped at address 0x7f86995000.
Value at address 0x54080940 (0x7f86995940): 0x30030
nvidia@tegra-ubuntu:~/yavta$ sudo devmem2 0x54080940
/dev/mem opened.
Memory mapped at address 0x7f9d3dd000.
Value at address 0x54080940 (0x7f9d3dd940): 0x30030

the 18bit and 17bit is high,What error is this?

What errors is the “TEGRA_CSI_CILX_STATUS 0x00030030”?

TEGRA_CSI_CILX_STATUS 0x00030030

hello sensor_test,

you could also check the Tegra X1 (SoC) Technical Reference Manual
http://developer.nvidia.com/embedded/dlc/tegra-x1-technical-reference-manual

for example,
there’s bit description of the CSI_CSI_CILA_STATUS_0
thanks

The 18 bit,17 bit,5 bit,4 bit have error.
How can fix this?

hello sensor_test,

please check my comment #2
first, you should co-work with your hardware engineer and checking this from the sensor side, to measure the mipi signaling is output correctly.
thanks

hello JerryChang,

Our hardware engineer check sensor mipi side,find the jetson TX1 mipi mclk can output Pulse waveform.
but the TX1 MIPI CLKN(G27) and CLKP(G28) pin,and CSI0_DN0(F28) pin, CSI0_DP0(F29) pin,and CSI0_DN1(H26) pin, CSI0_DP1(H27) pin, all always is output low level,can not output Pulse waveform.

WHY? How can fix this?

@sensor_test
For the MIPI tegra is input device the those pin should control by sensor. If you can’t see any signal on the MIPI bus that means sensor didn’t output any data to the bus.

Hi ShaneCCC,
Now I can find the "/dev/video0"device,that means the sensor probe is OK,right?

How can i send the iic data then the sensor output the data?

Contact with the sensor vendor to get the sensor i2c initial table write all the REG to output data to MIPI bus.

then kernel\kernel-4.4\drivers\media\i2c\imx219_mode_tbls.h file have the initial table ,is correct?or it is need the modify?

hello sensor_test,

you should also contact your sensor vendor since the register configuration have hardware dependencies sometimes.

Hi JerryChang,
Now I use the raspberry Pi v2 (imx219) modules,maybe you can offert some info at this?

hello sensor_test,

please refer to this topic: https://devtalk.nvidia.com/default/topic/975962/

I use logic analyzer the find the TX1 can imx219_mode_tbls.h file init table data below.
but now I can not find the sensor output picture some data.

static struct reg_8 mode_3280x2464[] = {
	{IMX219_TABLE_WAIT_MS, 10},
	/* software reset */
	{0x0103, 0x01},
	/* global settings */
	{0x30EB, 0x05},
	{0x30EB, 0x0C},
	{0x300A, 0xFF},
	{0x300B, 0xFF},
	{0x30EB, 0x05},
	{0x30EB, 0x09},
	{0x0114, 0x01},
	{0x0128, 0x00},
	{0x012A, 0x0C},
	{0x012B, 0x00},
	{0x0160, 0x09},
	{0x0161, 0xC3},
	{0x0162, 0x0D},
	{0x0163, 0x78},
	{0x0164, 0x00},
	{0x0165, 0x00},
	{0x0166, 0x0C},
	{0x0167, 0xCF},
	{0x0168, 0x00},
	{0x0169, 0x00},
	{0x016A, 0x09},
	{0x016B, 0x9F},
	{0x016C, 0x0C},
	{0x016D, 0xD0},
	{0x016E, 0x09},
	{0x016F, 0xA0},
	{0x0170, 0x01},
	{0x0171, 0x01},
	{0x0174, 0x00},
	{0x0175, 0x00},
	{0x018C, 0x0A},
	{0x018D, 0x0A},
	{0x0301, 0x05},
	{0x0303, 0x01},
	{0x0304, 0x02},
	{0x0305, 0x02},
	{0x0306, 0x00},
	{0x0307, 0x4C},
	{0x0309, 0x0A},
	{0x030B, 0x01},
	{0x030C, 0x00},
	{0x030D, 0x98},
	{0x4767, 0x0F},
	{0x4750, 0x14},
	{0x47B4, 0x14},
	/* stream on */
	{0x0100, 0x01},

This the logo info.

[ 4206.698851] imx219 6-0010: imx219_power_on++ power on 
[ 4206.758174] imx219 6-0010: imx219_get_fmt++ get_fmt 
[ 4206.763694] imx219 6-0010: imx219_s_stream++ s_stream 
[ 4206.768848] imx219 6-0010: imx219_write_table++ 
[ 4206.797102] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 0
[ 4206.804053] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 1
[ 4206.811140] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 2
[ 4206.818268] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 3
[ 4206.825315] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 4
[ 4206.832333] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 5
[ 4206.839336] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 6
[ 4206.846350] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 7
[ 4206.853318] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 8
[ 4206.860283] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 9
[ 4206.867252] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 10
[ 4206.874305] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 11
[ 4206.881333] vi 54080000.vi: tegra_channel_error_status:error 20002 frame 12
[ 4206.888355] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 13
[ 4206.895374] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 14
[ 4206.902393] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 15
[ 4206.909417] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 16
[ 4206.916434] vi 54080000.vi: tegra_channel_error_status:error 22 frame 17
[ 4206.923198] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 18
[ 4206.930221] vi 54080000.vi: tegra_channel_error_status:error 20002 frame 19
[ 4206.937239] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 20
[ 4206.944257] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 21
[ 4206.951288] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 22
[ 4206.958308] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 23
[ 4206.965326] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 24
[ 4206.972348] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 25
[ 4206.979367] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 26
[ 4206.986387] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 27
[ 4206.993407] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 28
[ 4207.000425] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 29
[ 4207.007442] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 30
[ 4207.014463] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 31
[ 4207.021483] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 32
[ 4207.028503] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 33
[ 4207.035524] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 34
[ 4207.042542] vi 54080000.vi: tegra_channel_error_status:error 20022 frame 35
[ 4207.049561] vi 54080000.vi: tegra_channel_error_status:error 20002 frame 36
[ 4207.056589] vi 54080000.vi: tegra_channel_error_status:error 20002 frame 37
[ 4207.132121] vi 54080000.vi: tegra_channel_error_status:error 24022 frame 39
[ 4207.139256] imx219 6-0010: imx219_s_stream++ s_stream 
[ 4207.161622] imx219 6-0010: imx219_power_off++ power off

hello sensor_test,

please review the gpio/ regulators/ mclk settings, please also co-work with your hardware engineer to measure these signals.
thanks