What version of jetpack has the feature "Kernel Boot Sequence " ?only jetpack4.5? how can we make a usb disk image with an easy way?

we flash the image failed with the sdkm (some unknow error)

so we flash a jp4.5 sd card,then let the nano has the feature of maxspi

then we can do the next step now

jp4.5 nano boot log.txt (18.7 KB)

but after we used once jp4.5 ,we can not boot our oldder version jp4.4 sd card any more. this is not happen in xavier nx. can fix this on nano later?

That is different issue. You can file different topic for it.

For jp4.5.1, just enter “boot” in your console to let it boot.

can we boot the usb disk which is flashed with this way:

we try that way to flashed the usb disk

but it can be booted up
usb disk boot log.txt (17.5 KB)


is there any easy way to flashed a usb disk avilabale?

Yeah, expected. Because you didn’t tell the kernel to mount the file system from the usb.
It still mounts from the sdcard.

append: tegraid= ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 gpt tegra_fbmem=0x140000@0x92ca9000 is_hdmi_initialised=1 earlycon=uart8250,mmio32,0x70006000 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0

You can read this post I just wrote.

thank you very much
we will try

we change ‘root=/dev/mmcblk0p1’ to ‘root=/dev/sda1’ in the /boot/extlinux/extlinux.conf

and we wait for a long time the system boot from the usb after power the nano no.
and the system on usb is running at a slow speed then on sd card,

why have to until wait for a long time, then the system boot from the usb dirve?
can we make the wait time shorter?

Dump the log and see what gets stuck.

usb disk boot log.txt (22.6 KB)

it will take us about 10 minutes to boot from the usb.(the hdmi monitor start the desktop)

Is this nvidia developer kit or your own custom carrier board?

More precisely, it takes 10 mins to enter the desktop. Not 10 mins to boot. The boot is finished when you see "vkrobot-desktop login: " on the uart console.

Please remove “quiet” inside your extlinux.conf to enable more log. Currently, the kernel log is not completed.

this is nvidia developer kit

we delete the “quiet” , it become faster to enter the desktop.(4~5 min)
usb disk boot log.txt (124.7 KB)

This is edid read failure. The display driver fails to read the monitor edid through the i2c. These re-tries make your desktop coming out slowly.

[ 5.292784] tegradc tegradc.0: hdmi: edid read failed
[ 5.292823] tegradc tegradc.0: hdmi: using fallback edid

Is this a A02 jetson nano or B01 one? Will you see such issue if you boot from sd?

this is a02

sd card boot log.txt (21.6 KB)

Remove the quiet please… so that I can check the log…

sd card boot log.txt (78.3 KB)
no quiet

sd card enter desktop ,it only take within 1 min

Both sdcard and usb disk has the same display error. Please check if you can use other board to validate this issue.

we change our usb which is higher r/w speed, then it enter the desktop very quickly now

but after we do apt-get update and apt-get upgrade , it no longer boot up .

stu at tegra-i2c : no acknowledge from address 0xxxx

This is jetson nano board issue… not the usb stick issue. That was what I am talking about in previous comment…

we already change the board
both are a02,
is the image not suitable for a02